Noob Q: Blank screen after installation

Asked by Mark A

Hi folks,

Trying to install Version 3.2.0 on XAMPP (Apache 2.4.7, MySQL 5.6.16 & PHP 5.5.9), on Win 7.

Install script runs to completion with no errors or warnings. When I go to the root of the site (in my case http://phpdev) I just get a blank screen.

I've tried a complete re-install twice following the instructions in readme/install

What am I doing wrong? Help and suggestions appreciated.


Question information

English Edit question
PHPDevShell Edit question
No assignee Edit question
Solved by:
Mark A
Last query:
Last reply:
Revision history for this message
Greg (gregfr) said :

Thanks for your interest in PHPDevShell.

The first places to look at in such a case are, in order:

- the webserver's log
- the logs files of your PHPDevShell installation (located in /write/logs)
- the console of your browser (F12 on Firefox and Chrome)

In my experience, a blank screen at that stage is the symptom of a javacript error: the browser stops executing the javascript code before the "show()" instruction, leaving you with a white page.

If you don't find a clue there, please send me these logs at <email address hidden> so I can look at them.


Revision history for this message
Mark A (s-mark-2) said :

Thanks Greg.

There is indeed an error report in the write/logs folder. The same one gets created everytime I try to run the site.

"mysql_connect(): Access denied for user 'root'@'localhost' (using password: YES)

The error occurred in file C:\xampp\htdocs\phpdev\includes\PHPDS_legacyConnector.class.php at line 137'

Not quite sure what this actually means but I will try to dig into it further unless anyone here knows what the answer is.



Revision history for this message
Greg (gregfr) said :

The error message is:

"mysql_connect(): Access denied for user 'root'@'localhost' (using password: YES)

That means that PHPDevShell tried to connect to the database server running on the same computer, using the account "root" and a password (which is not displayed for security reasons) - and that connection was rejected by the database server.

If you indeed intend to connect using the "root" account, you probably mistyped the password. If you created a special account for the site (the prefered way of doing things), either you forgot to specify its name, or you edited the wrong config file.

Revision history for this message
Mark A (s-mark-2) said :

Thanks. Sorted now. Idiot error. Everything was correct all along but I'd re-named the config file incorrectly (twice!)



Revision history for this message
Greg (gregfr) said :

Good. I'll try to see if we can provide a better feedback than a blank screen.

Happy coding!

Revision history for this message
Liviu Ivan (jocnouro) said :

Thank you for this this is perfect!
 [url=""]jocuri cu catei[/url]