I can't log out from an account

Asked by Gabriel on 2011-04-29

Each time I wanted to log out from my account, this message appear:

SECURITY ALERT, There seems to be a security limitation, you are not allowed to run this script or the script could not be found. Make sure your session did not expire, you might be logged out.

What can I do?

Question information

Language:
English Edit question
Status:
Solved
For:
PHPDevShell Edit question
Assignee:
No assignee Edit question
Solved by:
TitanKing
Solved:
2011-05-03
Last query:
2011-05-03
Last reply:
2011-05-03
Greg (gregfr) said : #1

Please ensure the page you set as "log out" page (in PHPDS's system prefs) is actually accessible to "guest" ("guest" is the default identity when the user is not actually logged in)

Gabriel (gabriel-rodrigues) said : #2

I mean:

When I'm connected, in my dashboard page, and I wanted to connect with another account to make some tests, I can't.
I wanted to log out from this account and the SECURITY ALERT is sent to me...

TitanKing (titan-phpdevshell) said : #3

Yes, I do think the problem is the fact that you dont gave guest permission to log-out. Give role "Guest" permission to access log-out page.

Gabriel (gabriel-rodrigues) said : #4

Ok, but how can I do that.. I can't log out from this account, so how can I can log in another account to give this permission?

TitanKing (titan-phpdevshell) said : #5

Ok so I assume you are not logged in as root. Ok I think the best would be is to just set the default permissions for now:

Execute from a applications like PHPMyAdmin this SQL:
INSERT INTO pds_core_user_role_permissions VALUES ('', '5', '3682403894');

This simply gives group 5 which should be guest group permission to access the logout-login page.

Tell us if this works :)

Gabriel (gabriel-rodrigues) said : #6

It doesn't work..

Maybe I put it in a wrong area.. I've to paste it in "pds_core_user_role_permissions", right?

Best TitanKing (titan-phpdevshell) said : #7

Very odd, have you tried doing a fresh installation?

Gabriel (gabriel-rodrigues) said : #8

I've made it two times before this bug, so I'm not very motivated to do it one more time..

TitanKing (titan-phpdevshell) said : #9

If this happens every time on a fresh installation there must be something wrong with your MySQL server that is not inserting data correctly.

After you do a fresh install, is it broken immediately? What exactly are you doing when this starts happening?