a question about export with innobackupex

Asked by snowave on 2013-07-03

mysql version : percona 5.5.21
xbackversion : 2.1.3-608

step 1:

innobackupex -xx -xx /tmp/

step 2:

innobackupex --apply-log --export /tmp/path_to_backup/

step3, login mysql
alter table xx discard tablespace && cp /tmp/path_to_backup/table.exp table.ibd to datadir

step4 , chown user

step5, alter table xx import tablespace , the file size of ibd file is ok, but execute select * from table, return o rows.

Question information

Language:
English Edit question
Status:
Solved
For:
Percona XtraBackup moved to https://jira.percona.com/projects/PXB Edit question
Assignee:
No assignee Edit question
Solved by:
Alexey Kopytov
Solved:
2013-07-05
Last query:
2013-07-05
Last reply:
2013-07-05
Best Alexey Kopytov (akopytov) said : #1

Hi,

I saw this problem on 5.5.21, but then the issue magically disappeared somewhere between 5.5.21 and 5.5.24 (see bug #983692). We didn't investigate what exactly fixed it due to limited time. Please let us know if you see this problem on Percona Server versions >= 5.5.24.

snowave (shawn001) said : #2

thanks , with 5.5.24. it works well!

snowave (shawn001) said : #3

Thanks Alexey Kopytov, that solved my question.