Using the --databases option

Asked by Rob Lampe on 2013-04-08

Hi,

Version Info:

# cat /etc/issue
CentOS release 5.9 (Final)
# xtrabackup -v
xtrabackup version 2.0.6 for Percona Server 5.1.59 unknown-linux-gnu (x86_64) (revision id: 521)
# innobackupex -v
InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
and Percona Ireland Ltd 2009-2012. All Rights Reserved.

This software is published under
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

mysql> SELECT VERSION();
+-----------------+
| VERSION() |
+-----------------+
| 5.5.30-30.1-log |
+-----------------+
1 row in set (0.00 sec)

Problem:

I am having an issue getting Percona Xtrabackup to only backup specified databases using the --databases option. My server has about 12 databases and I only want to backup two of them.

I ran the following:

# innobackupex --user=<user> --password=<password> --databases="<database1> <database2>" <backup directory>

innobackupex runs and backups up ALL of the databases instead of two of them. I have also tried creating a txt file with the database names and specifying that instead.

Thank you for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Percona XtraBackup moved to https://jira.percona.com/projects/PXB Edit question
Assignee:
No assignee Edit question
Solved by:
Rob Lampe
Solved:
2013-04-08
Last query:
2013-04-08
Last reply:
2013-04-08
Alexey Kopytov (akopytov) said : #1

Rob,

This is a known limitation with --databases having effect only with the --stream option is used, see bug #569387. The workaround is to use the --include option as suggested in the bug report.

We have a fix for that bug which is currently under review. We'll try to get it released in the next XtraBackup version.

Rob Lampe (rlampe-4) said : #2

Awesome. Thank you!