Xtrabackup 2.0.5 Failed streaming backup

Asked by Teggy Kwon on 2013-01-29

Hello,

I met following error when I execute streaming backup in Xtrabackup 2.0.5,
but completed successfully using same backup command in Xtrabckup 2.0.1.

----------
Log & Error:
130129 11:37:45 innobackupex: Finished backing up non-InnoDB tables and files
130129 11:37:45 innobackupex: Waiting for log copying to finish

[Teggy-Debug] pid: 0, ibbackup_pid: 12323
[Teggy-Debug] /tmp/xtrabackup_suspended not exists
xtrabackup: The latest check point (for incremental): '83978939473'
xtrabackup: Stopping log copying thread.
.>> log scanned up to (83978939473)

xtrabackup: Streaming transaction log from a temporary file...
xtrabackup: Done.
xtrabackup: Transaction log of lsn (83978939473) to (83978939473) was copied.
[Teggy-Debug] pid: 12323, ibbackup_pid: 12323
[Teggy-Debug] /tmp/mytemp/xtrabackup_suspended not exists
innobackupex: Error: ibbackup child process has died at /opt/mysql/xtrabackup-2.0.5/bin/innobackupex line 381.

----------
PID:
root 12283 12282 0 11:36 pts/1 00:00:00 perl /opt/mysql/xtrabackup-2.0.5/bin/innobackupex --host=127.0.0.1 --user=backupuser --password=password --port=3306 --throttle=300 --slave-info --tmpdir=/tmp --stream=xbstream /backup
root 12323 12283 10 11:36 pts/1 00:00:00 xtrabackup_55 --defaults-group=mysqld --backup --suspend-at-end --target-dir=/tmp --throttle=300 --stream=xbstream

----------
Backup Command:
innobackupex \
  --host=127.0.0.1 \
  --user=backupuser \
  --password=password \
  --port=3306 \
  --throttle=300 \
  --slave-info \
  --defaults-file=/etc/my.cnf \
  --stream=xbstream /tmp > /backup/test01.xbs

Is it a bug?
I guess Xtrabackup can not created again 'xtrabackup_suspended' when the resume_ibbackup subroutine is called.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Percona XtraBackup moved to https://jira.percona.com/projects/PXB Edit question
Assignee:
No assignee Edit question
Solved by:
Alexey Kopytov
Solved:
2013-01-29
Last query:
2013-01-29
Last reply:
2013-01-29
Best Alexey Kopytov (akopytov) said : #1

It might be the case when innobackupex 2.0.5 calls the xtrabackup binary from a previous release, so the xtrabackup binary does not create the lock file as newer innobackupex expects.

I suggest you also adjust PATH to make sure correct xtrabackup binaries are called by innobackupex:

PATH=/opt/mysql/xtrabackup-2.0.5/bin:$PATH innobackupex --host=127.0.0.1 --user=backupuser --password=password --port=3306 --throttle=300 --slave-info --tmpdir=/tmp --stream=xbstream /backup

Teggy Kwon (wing3a07) said : #2

Thanks Alexey Kopytov, that solved my question.