Help on XFS Warnings

Asked by Otávio Fernandes on 2012-02-13

With normal Xtrabackup (1.6.4) usage, I've realize the following warnings on "dmesg" output:

[17576101.830273] ------------[ cut here ]------------
[17576101.830301] WARNING: at
/build/buildd-linux-2.6_2.6.32-35-amd64-aZSlKL/linux-2.6-2.6.32/debian/buil
d/source_amd64_none/fs/xfs/linux-2.6/xfs_lrw.c:714 xfs_write+0x3c9/0x6ea
[xfs]()
[17576101.830305] Hardware name: PowerEdge R710
[17576101.830306] Modules linked in: ip6table_filter ip6_tables
iptable_filter ip_tables x_tables bonding xfs exportfs ipmi_si
ipmi_devintf ipmi_msghandler usbhid hid ohci_hcd snd_pcm snd_timer dcdbas
snd soundcore snd_page_alloc psmouse pcspkr evdev serio_raw power_meter
button processor ext3 jbd mbcache sg sr_mod cdrom ata_generic ses sd_mod
crc_t10dif enclosure ata_piix libata uhci_hcd megaraid_sas ehci_hcd
usbcore nls_base scsi_mod thermal bnx2 thermal_sys [last unloaded:
scsi_wait_scan]
[17576101.830338] Pid: 30992, comm: mysqld Tainted: G W
2.6.32-5-amd64 #1
[17576101.830340] Call Trace:
[17576101.830355] [<ffffffffa0298490>] ? xfs_write+0x3c9/0x6ea [xfs]
[17576101.830369] [<ffffffffa0298490>] ? xfs_write+0x3c9/0x6ea [xfs]
[17576101.830375] [<ffffffff8104df20>] ? warn_slowpath_common+0x77/0xa3
[17576101.830381] [<ffffffff810680a2>] ? up_write+0x14/0x15
[17576101.830394] [<ffffffffa0298490>] ? xfs_write+0x3c9/0x6ea [xfs]
[17576101.830408] [<ffffffff810eea32>] ? do_sync_write+0xce/0x113
[17576101.830414] [<ffffffff8100f6c4>] ? __switch_to+0x1ad/0x297
[17576101.830418] [<ffffffff81064f1a>] ? autoremove_wake_function+0x0/0x2e
[17576101.830425] [<ffffffff81048271>] ? finish_task_switch+0x3a/0xaf
[17576101.830430] [<ffffffff810ef384>] ? vfs_write+0xa9/0x102
[17576101.830434] [<ffffffff810ef434>] ? sys_pwrite64+0x57/0x77
[17576101.830439] [<ffffffff8101195b>] ? device_not_available+0x1b/0x20
[17576101.830442] [<ffffffff81010b42>] ? system_call_fastpath+0x16/0x1b
[17576101.830444] ---[ end trace eb1d649fc925c30d ]---

And I'm worried with the filesystem consistency, is this a bug or what is triggering?

thanks in advance,

-- OF

Question information

Language:
English Edit question
Status:
Solved
For:
Percona XtraBackup moved to https://jira.percona.com/projects/PXB Edit question
Assignee:
Alexey Kopytov Edit question
Solved by:
Alexey Kopytov
Solved:
2012-02-13
Last query:
2012-02-13
Last reply:
2012-02-13
Best Alexey Kopytov (akopytov) said : #1

Otávio,

That warning is most likely triggered by bug #925354. It occurs when the server is configured with innodb_flush_method=O_DIRECT.

That bug has been fixed in recently released XtraBackup 1.6.5, please upgrade to that version and let us know if you have this issue with 1.6.5.

Don't worry about the filesystem consistency, it's just a warning from XFS that the application (xtrabackup in this case) is doing something wrong. So the backup produced by xtrabackup *might* be broken, but the original data and the filesystem is safe.

Otávio Fernandes (otaviof) said : #2

Thanks Alexey Kopytov, that solved my question.