Why mysql has connected to IP 74.121.199.231

Asked by Grzegorz D on 2013-08-21

Hi,

One of our mysql instance (Percona-Server-5.1.68-rel14.6) was catch trying connect to address 74.121.199.231:
Aug 19 02:30:01 mysql-int kernel: [7578158.973167] FWINT INT->INTERNET:IN=eth1 OUT=eth0 SRC=10.0.0.5 DST=74.121.199.231 LEN=60 TOS=0x00 PREC=0x00 TTL=63 ID=19978 DF PROTO=TCP SPT=53415 DPT=443 WINDOW=14600 RES=0x00 SYN URGP=0

2 Question about this incident:
1) Why this connection was made ?
2) What is send over this connection (this one was block)

Question information

Language:
English Edit question
Status:
Answered
For:
Percona Server moved to https://jira.percona.com/projects/PS Edit question
Assignee:
No assignee Edit question
Last query:
2013-08-21
Last reply:
2013-08-22

This question was reopened

Alexey Kopytov (akopytov) said : #1

Grzegorz,

74.121.199.231 is the IP address of v.percona.com which is the server for Percona Version Check database. The version check feature is currently supported by some tools in Percona Toolkit, is disabled by default, and can be enabled by passing the --version-check option to some utilities from PT. You can read more about it here: http://www.mysqlperformanceblog.com/2012/09/10/introducing-the-version-check-feature-in-percona-toolkit/

Grzegorz D (test123-h) said : #2

Indeed there is a weekly report from pt-query-digest in our cron. But your information is different then one in man:
       --[no]version-check
           default: yes
           Check for the latest version of Percona Toolkit, MySQL, and other programs.

So to disable this feature one should add --noversion-check (probably some one in the way has changed the default behaviour of this option). Thx

Can you help with this problem?

Provide an answer of your own, or ask Grzegorz D for more information if necessary.

To post a message you must log in.