Play/Pause button initially Stop button

Asked by cross157 on 2009-11-08

I noticed this after updating to 0.5.3, the initial behaviour of the Play/Pause button is Play/Stop. I love Panflute this is minor thing, not sure if its a bug or the intended behaviour. Here are some screen shots to illustrate:

When initially started by clicking on mp3 file using VLC, Play/Pause button is Stop only:
http://ubuntuforums.org/picture.php?albumid=1475&pictureid=5164

If I click Pause on VLC, the button changes to a Play button:
http://ubuntuforums.org/picture.php?albumid=1475&pictureid=5165

Then click Play on VLC or on Panflute changes button to Play/Pause:
http://ubuntuforums.org/picture.php?albumid=1475&pictureid=5166

Question information

Language:
English Edit question
Status:
Answered
For:
Panflute Edit question
Assignee:
No assignee Edit question
Last query:
2009-11-09
Last reply:
2009-11-12
Paul Kuliniewicz (kuliniew) said : #1

Which version of VLC are you using? Some initial testing suggests the version of VLC in Karmic (1.0.2-1ubuntu2) doesn't reliably signal when its state changes, causing Panflute to get out of sync with it. That could definitely explain the behavior you're describing.

cross157 (cross157) said : #2

Hi Paul, I'm running version 1.0.3-1~ppa1, I should have included that sorry.

Paul Kuliniewicz (kuliniew) said : #3

I think VLC might have changed its behavior from 0.9 to 1.0, and that's confusing Panflute. I'm creating a bug report for this.

Can you help with this problem?

Provide an answer of your own, or ask cross157 for more information if necessary.

To post a message you must log in.