Panflute not working with any preferred player

Asked by tako on 2010-05-21

I can't get Panflute to work with any of the preferred players that it supports. I tried it with every player that I have installed under Lucid Lynx. I installed the MPRIS addon for Songbird, removed applet from panel before I ran the Panflute debug to see if it recognized Songbird (which it did) and I still get nothing. Applet still says not playing and neither the play/previous song/next song buttons do anything while playing songs in Songbird. What am I doing wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Panflute Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Kuliniewicz
Solved:
2010-06-22
Last query:
2010-06-22
Last reply:
2010-06-20
Paul Kuliniewicz (kuliniew) said : #1

Is there anything interesting in the log files stored under ~/.local/share/panflute/ ?

Do you have another player running alongside Songbird, with Panflute paying attention to it instead?

tako (takotheoktopus) said : #2

I have only tested Panflute with one audio player running at a time and made sure to set the correct player in the preferred player option under preferences. I've tried the following players with no luck; VLC, SongBird, Audacious, Exaile.

applet.log and applet.stdout are both empty. Here's the output for applet.stderr:

/usr/lib/pymodules/python2.6/panflute/applet/widget.py:309: DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use PyArray_NewFromDescr.
  pixels = pixbuf.get_pixels_array ()
/usr/lib/pymodules/python2.6/panflute/applet/widget.py:861: DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use PyArray_NewFromDescr.
  for row in pixbuf.get_pixels_array ():

(panflute-applet:12544): Bonobo-WARNING **: Failed to get '/desktop/gnome/interface/menus_have_icons': 'Type mismatch: Expected `bool' got `string' for key /desktop/gnome/interface/menus_have_icons'

Paul Kuliniewicz (kuliniew) said : #3

I haven't had the chance to try to get Songbird working again on my system, so I'm having trouble trying to reproduce this.

The problem may be on the daemon side of things. Remove the applet and kill the panflute-daemon process. Launch it manually from the command line with the -d flag (panflute-daemon -d) to put it into debugging mode. Start Songbird and let me know if any error messages get printed out that might indicate what's going on.

tako (takotheoktopus) said : #4

Hey Paul, sorry for the delay.

 I did as you suggested. I removed panflute from the panel, I tried searching for the panflute-daemon process under my system monitor but found no such process even when panflute was showing up on my panel. I found a related process that pops up with the musical note icon and is titled python. It disapearred from the process list as soon as I removed panflute from the panel. Here is the debug output after removing panflute from panel and starting songbird and playing a song, skipping song and then exiting songbird.

INFO [panflute.daemon.amarok.Connector] Failed to load Amarok 1.4 connector: No module named dcopext
[Pyinotify ERROR] add_watch: cannot watch /home/tako/.moc (WD=-1)
ERROR [pyinotify] add_watch: cannot watch /home/tako/.moc (WD=-1)
DEBUG [panflute.daemon.mpd.Connector] Resume polling
DEBUG [panflute.daemon.mpd.Connector] Registering the poll source
DEBUG [panflute.daemon.mpd.Connector] Attempting to connect to localhost:6600
DEBUG [panflute.daemon.mpd.Connector] Connection established
DEBUG [panflute.daemon.mpd.Connector] Connection status changed to True
DEBUG [panflute.daemon.mpd.Connector] Removing the poll source
INFO [panflute.daemon.manager.Manager] Failed to load XMMS connector: No module named xmms.control
DEBUG [panflute.daemon.xmms2.Connector] Resume polling
DEBUG [panflute.daemon.xmms2.Connector] Registering the poll source
DEBUG [panflute.daemon.xmms2.Connector] Attempting to connect to XMMS2
DEBUG [panflute.daemon.xmms2.Connector] Connection failed
DEBUG [panflute.daemon.manager.Manager] Preferred player is now songbird
DEBUG [panflute.daemon.manager.Manager] scanning for connected players
DEBUG [panflute.daemon.manager.Manager] exposing mpd
DEBUG [panflute.daemon.xmms2.Connector] Stop polling
DEBUG [panflute.daemon.xmms2.Connector] Removing the poll source
DEBUG [panflute.daemon.mpd.Connector] Stop polling
DEBUG [panflute.daemon.mpd.Player] sending CapsChange 0xb
DEBUG [panflute.daemon.mpd.Player] sending StatusChange (2, 0, 0, 0)
DEBUG [panflute] Running panflute-daemon
DEBUG [panflute.daemon.mpd.IdleThread] Sleeping
DEBUG [panflute.daemon.manager.Manager] songbird status is now True
DEBUG [panflute.daemon.mpd.Player] Keep-alive ping
DEBUG [panflute.daemon.mpd.Player] Keep-alive ping
DEBUG [panflute.daemon.manager.Manager] songbird status is now False
DEBUG [panflute.daemon.mpd.Player] Keep-alive ping

Paul Kuliniewicz (kuliniew) said : #5

Ah, here's the culprit:

DEBUG [panflute.daemon.mpd.Connector] Attempting to connect to localhost:6600
DEBUG [panflute.daemon.mpd.Connector] Connection established
DEBUG [panflute.daemon.mpd.Connector] Connection status changed to True

You have MPD running too, and Panflute sees that before it sees Songbird, so it pays attention to MPD instead of Songbird, and will continue to do so until MPD terminates.

The "Preferred player" option only determines which player gets launched if nothing is running and you click on the applet; it has no influence over which player "wins" out over another if more than one is running.

tako (takotheoktopus) said : #6

How do I permanently stop MPD from running?

Best Paul Kuliniewicz (kuliniew) said : #7

It depends on how it's getting started. If it's a system-wide MPD, on Ubuntu or Debian you can stop it from getting started by editing /etc/default/mpd; on other distros you'd need to use whatever the appropriate mechanism is. If it's a session-level MPD, don't run whichever MPD client started it.

tako (takotheoktopus) said : #8

Thanks Paul Kuliniewicz, that solved my question.

tako (takotheoktopus) said : #9

Hi Paul, I just wanted to thank you once more for all your help. I edited the line in the /etc/default/mpd file to START_MPD=false and now Panflute works!