dll load error

Asked by Theo

After having installed oursql I get a dll load failure when I import the module.

from oursql import *
Traceback (most recent call last):
  File "<pyshell#2>", line 1, in <module>
    from oursql import *
ImportError: DLL load failed: The specified procedure could not be found.

As you can see the oursql module is loaded but then it tries to load a dll file.
Can anyone tell me which dll files are involved ?

Question information

English Edit question
oursql Edit question
No assignee Edit question
Solved by:
Kurtis Mullins
Last query:
Last reply:
Revision history for this message
Theo (t-mars) said :

The platform I work on is XP prof sp3
I checked the module ourslq.pyd and found 5 .dll files mentioned.
libmysql.dll, kernel32.dll, msvcr90.dll, msvcrt.dll and python31.dll.
All .dll files where there and on the windows path setting.

I still get the error. I also installed oursql on a xp x64 system and there I did'nt encounter any problems.
Can .dll versions cause thes problems ??

Revision history for this message
Best Kurtis Mullins (kurtis-mullins-deactivatedaccount) said :

I ran into a similar problem but on Windows 7 64-bit.

My solution is here: http://binary-green.blogspot.com/2010/09/fixing-dll-error-with-oursql-on-windows.html

Good luck!

Revision history for this message
Theo (t-mars) said :

This indeed solved the problem.
As mentioned in my question I checked several dll files and they were all in the windows path.
This however is not enough and your solution did the trick.
Thanks for your help.