OpenWNS running on a 64 bit system?

Asked by Hendrik on 2009-07-07

Hi,
i successfully made it to the end of the installation routine, running the test suite says everything is okay, but openwns is still not running though...

I am using ubuntu 9.04 - 64 bit version, might this be a problem or can someone rule this out?

Cheers
Hendrik

Question information

Language:
English Edit question
Status:
Solved
For:
openWNS-Application Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Bültmann
Solved:
2009-07-08
Last query:
2009-07-08
Last reply:
2009-07-08

Hendrik wrote:
> New question #76315 on openWNS-Application:
> https://answers.launchpad.net/openwns-application/+question/76315
>
> Hi,
> i successfully made it to the end of the installation routine, running the test suite says everything is okay, but openwns is still not running though...
>
> I am using ubuntu 9.04 - 64 bit version, might this be a problem or can someone rule this out?
>
> Cheers
> Hendrik
>
>
Dear Hendrik,

we haven't done much testing on 64 bit, yet. If the test suite is
running, then openwns should run, too. What exactly do you mean
by "openwns is still not running though". You need to give some more
information on what you are trying to do and what is the error
you get. Could you check the test suite again by doing:

cd tests/unit/unitTests
./openwns -tv

Does openwns execute a lot of test cases (~ 1200) and does it tell you
that each test case is "[OK]" ? If yes, what exactly does not
work for you?

Regards,
  Daniel

Hendrik (mostricht) said : #2

Hi Daniel,
thanks for your speedy reply!

What i managed to do is:

./openwns -t -v saying:
OK [1068 tests]

./playground.py runtests saying:
Ran 2097 tests in 308.975s [OK]

I installed the wrowser and postgresql 8.3 and created a user.

Then i tried to run the tutorial according to the UserGuide by preparing a campaign:
./playground.py preparecampaign ../myFirstCampaign

------------------------------------------------------------------------------------------------------------------------------------------
Preparing simulation campaign. Please wait...
No handlers could be found for logger "bzr"
Do you want to use the database server for storing simulation campaign related data? (y/N) y
Please enter the name of the directory the simulations shall be stored in [simulations]: firstexperiment
Please enter a name for the campaign: firstcampaign
Please enter a short description of the campaign: test test test
Traceback (most recent call last):
  File "./playground.py", line 103, in <module>
    core.run()
  File "/home/ko/myOpenWNS/wnsbase/playground/Core.py", line 187, in run
    self.command.run()
  File "/home/ko/myOpenWNS/wrowser/wrowser/playgroundPlugins/SimulationCampaign/__init__.py", line 229, in run
    PrepareCampaign.createNewSubCampaign(directory)
  File "/home/ko/myOpenWNS/wrowser/wrowser/playgroundPlugins/SimulationCampaign/PrepareCampaign.py", line 91, in createNewSubCampaign
    cursor.execute('INSERT INTO campaigns (title, description) VALUES (\'%s\', \'%s\')' % (campaignTitle, campaignDescription))
psycopg2.IntegrityError: null value in column "id" violates not-null constraint
------------------------------------------------------------------------------------------------------------------------------------------

Then, the installation procedure does not start...

Sebastian Max (smx-comnets) said : #3

Hi Hendrik,

although it does not solve your problem, please take a look at the question and answers posted at
https://answers.launchpad.net/openwns-wifimac/+question/74899

Essentially, it is the same problem. I would propose to continue the debugging there - we are still working on it, but have problems to reproduce the error.

BR,
Sebastian

Dear Hendrik,

this is a duplicate of kharny's question.

https://answers.launchpad.net/openwns-wifimac/+question/74899

It seems that this is more a bug than a question. I filed a bug report.
I suggest that we continue the discussion there. Here is the link:

https://bugs.launchpad.net/openwns-wrowser/+bug/396985

Regards,
  Daniel

Hendrik wrote:
> Question #76315 on openWNS-Application changed:
> https://answers.launchpad.net/openwns-application/+question/76315
>
> Status: Answered => Open
>
> Hendrik is still having a problem:
> Hi Daniel,
> thanks for your speedy reply!
>
> What i managed to do is:
>
> ./openwns -t -v saying:
> OK [1068 tests]
>
> ./playground.py runtests saying:
> Ran 2097 tests in 308.975s [OK]
>
> I installed the wrowser and postgresql 8.3 and created a user.
>
> Then i tried to run the tutorial according to the UserGuide by preparing a campaign:
> ./playground.py preparecampaign ../myFirstCampaign
>
> ------------------------------------------------------------------------------------------------------------------------------------------
> Preparing simulation campaign. Please wait...
> No handlers could be found for logger "bzr"
> Do you want to use the database server for storing simulation campaign related data? (y/N) y
> Please enter the name of the directory the simulations shall be stored in [simulations]: firstexperiment
> Please enter a name for the campaign: firstcampaign
> Please enter a short description of the campaign: test test test
> Traceback (most recent call last):
> File "./playground.py", line 103, in <module>
> core.run()
> File "/home/ko/myOpenWNS/wnsbase/playground/Core.py", line 187, in run
> self.command.run()
> File "/home/ko/myOpenWNS/wrowser/wrowser/playgroundPlugins/SimulationCampaign/__init__.py", line 229, in run
> PrepareCampaign.createNewSubCampaign(directory)
> File "/home/ko/myOpenWNS/wrowser/wrowser/playgroundPlugins/SimulationCampaign/PrepareCampaign.py", line 91, in createNewSubCampaign
> cursor.execute('INSERT INTO campaigns (title, description) VALUES (\'%s\', \'%s\')' % (campaignTitle, campaignDescription))
> psycopg2.IntegrityError: null value in column "id" violates not-null constraint
> ------------------------------------------------------------------------------------------------------------------------------------------
>
> Then, the installation procedure does not start...
>
>

Hendrik (mostricht) said : #5
Hendrik (mostricht) said : #6

Thanks Daniel Bültmann, that solved my question.

Hendrik (mostricht) said : #7

to answer the topic:
OpenWNS does run under a 64 bit system!

Whoohoo!

That is great news. Hendrik, I would like to thank you very much for
your beta testing. Unfortunately, we did not have the time by now
to check this ourselves. Thanks!

So to summarize your effort - is it true to say:

Ubuntu Jaunty 64bit is a supported platform for openWNS? We still have
to clarify if postgres 8.3.xx works (that is the postgresql version
shipped with Ubuntu 9.04).

Regards,
  Daniel

Hendrik wrote:
> Question #76315 on openWNS-Application changed:
> https://answers.launchpad.net/openwns-application/+question/76315
>
> Hendrik posted a new comment:
> to answer the topic:
> OpenWNS does run under a 64 bit system!
>

Hendrik (mostricht) said : #9

Hi,
yes - it is true, Ubuntu Jaunty 64bit is a supported platform for openWNS!

If i find a fix for the postgres 8.3 problem, i'll let you know!

Regards,
Hendrik

Hendrik (mostricht) said : #10

Hi everybody,
I just found out that postgres 8.3.10 works just fine!

BR