Problem using OpenUpgrade on a 6.1 Database

Asked by Sylvain LE GAL (GRAP)


after the execution of the migration script 6.1 to 7 openupgrade I got the following errors, please help to solve the problem.

updating 6.1/web rev2538
Traceback (most recent call last):
  File "./", line 268, in <module>
    dir=os.path.join(options.branch_dir, version, name))
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1791, in run
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1473, in update
    return self._update_tree(old_tip, change_reporter, revision, show_base)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 52, in tree_write_locked
    return unbound(self, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1522, in _update_tree
    to_tree = self.branch.repository.revision_tree(revision)
  File "<string>", line 4, in revision_tree_read_locked
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1839, in revision_tree
    inv = self.get_inventory(revision_id)
  File "<string>", line 4, in get_inventory_read_locked
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1732, in get_inventory
    return self.iter_inventories([revision_id]).next()
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1750, in iter_inventories
    for inv, revid in self._iter_inventories(revision_ids, ordering):
  File "/usr/lib/python2.7/dist-packages/bzrlib/repofmt/", line 982, in _iter_inventories
    for record in stream:
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1456, in get_record_stream
    orig_keys, ordering, include_delta_closure):
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1617, in _get_remaining_record_stream
    for factory in batcher.yield_factories(full_flush=True):
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1170, in yield_factories
    block_read_memo, block =
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1412, in _get_blocks
    zdata =
  File "/usr/lib/python2.7/dist-packages/bzrlib/repofmt/", line 2043, in get_raw_records
    for names, read_func in reader.iter_records():
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 279, in iter_records
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 320, in _read_format
    format = self._read_line()
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 247, in _read_line
    line = self._source.readline()
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 210, in readline
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 195, in _next
    offset, data =
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/", line 201, in _readv
    for cur_coal, rfile in self._coalesce_readv(relpath, coalesced):
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/", line 293, in _coalesce_readv
    for c, rfile in get_and_yield(relpath, ranges):
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/", line 256, in get_and_yield
    code, rfile = self._get(relpath, coalesced)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/", line 120, in _get
    response = self._perform(request)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/", line 76, in _perform
    response =
  File "/usr/lib/python2.7/", line 410, in open
    response = meth(req, response)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/", line 1806, in http_response
    code, msg, hdrs)
  File "/usr/lib/python2.7/", line 448, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.7/", line 382, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/", line 1819, in http_error_default
    ' for %s' % req.get_full_url())
bzrlib.errors.TransportError: Transport error: Server refuses to fulfill the request (403 Forbidden) for

Thanks for your attention.

Question information

English Edit question
OpenUpgrade Server Edit question
No assignee Edit question
Solved by:
Stefan Rijnhart (Opener)
Last query:
Last reply:
Revision history for this message
Best Stefan Rijnhart (Opener) (stefan-opener) said :

Thanks for the bugfix. Someone else reported and fixed it too, here:

Q1: See for more info

Q2: Yes, we need to develop a module that facilitates controlled removal of unused columns and tables. Wanted but not planned.

Q3: Upgrade related columns need to be available for migration scripts of other modules that have such a module as a dependency, and for debugging purposes. For cleanup, same as Q2.

Revision history for this message
Sylvain LE GAL (GRAP) (sylvain-legal) said :

Thanks Stefan Rijnhart (Therp), that solved my question.