Unable to install program

Asked by deliveryman on 2016-04-02

Hello,
I have Linux xubuntu using xfce4 desktop. Linux kernel 3.19.0-33 generic (x86_64) Ubuntu 15.04 I am unable to download openshot. I use Ubuntu Software Center. I can find openshot and click install. I get an error message immediately.

The following packages have unmet dependencies.
openshot: Depends: python (>=2.5) but 2.7.9-1 is to be installed

I am not a linux whiz but it seems the message is suggesting I need to have python version 2.7.9-1 installed.

While still in ubuntu software center, I input python. Python is installed. I have no idea what version. Some of the text displayed on the python page says " This package is a dependency package, which depends on Debian's default python version (currently version 2.7)

I'm assuming I have Python 2.7 installed? I'm at a loss as to what the system needs. Is there a relatively easy fix to this? I'd love to be able to have openshot. Thank you so much for your time and feedback

Question information

Language:
English Edit question
Status:
Solved
For:
OpenShot Video Editor Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2016-04-06
Last query:
2016-04-06
Last reply:
2016-04-06
deliveryman (ronjnk) said : #1

I went back in to Ubuntu software center and clicked on installed software tab. Under developer tools is Python (v3.4) Python Interpreter. Means nothing to me but hopefully helps you in diagnosis. Again, thank you! Ron

Manfred Hampl (m-hampl) said : #2

Try the following:

Open a terminal window (e.g. by simultaneously pressing ctrl-alt-t)

and issue the commands

sudo apt-get update
apt-cache policy openshot
sudo apt-get install openshot

then use the terminal window's menu entries "edit - select all" and "edit - copy" and paste everything as a new message into this question document that you have already created.

deliveryman (ronjnk) said : #3

Hello Manfred,
I truly appreciate your help on this. If this is too complicated, I'll just have to use the movie maker in windows which is a drag. I'm very sensitive to taking a lot of your time here. Thank you!

bushguy@bushguy:~$ sudo apt-get update
[sudo] password for bushguy:
Hit http://archive.ubuntu.com vivid InRelease
Hit http://archive.ubuntu.com vivid/universe amd64 Packages
Hit http://archive.ubuntu.com vivid/main amd64 Packages
Hit http://archive.ubuntu.com vivid/multiverse amd64 Packages
Hit http://archive.ubuntu.com vivid/universe i386 Packages
Hit http://archive.ubuntu.com vivid/main i386 Packages
Hit http://archive.ubuntu.com vivid/multiverse i386 Packages
Get:1 http://archive.ubuntu.com vivid/main Translation-en_CA [582 kB]
Hit http://archive.ubuntu.com vivid/main Translation-en
Hit http://archive.ubuntu.com vivid/multiverse Translation-en
Get:2 http://archive.ubuntu.com vivid/universe Translation-en_CA [3,575 kB]
Hit http://archive.ubuntu.com vivid/universe Translation-en
Fetched 4,157 kB in 45s (90.6 kB/s)
Reading package lists... Done
bushguy@bushguy:~$ apt-cache policy openshot
openshot:
  Installed: (none)
  Candidate: 1.4.3-1.1
  Version table:
     1.4.3-1.1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
bushguy@bushguy:~$ sudo apt-get install openshot
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 openshot : Depends: melt but it is not going to be installed
            Depends: python-mlt but it is not going to be installed or
                     python-mlt5 but it is not installable or
                     python-mlt2 but it is not installable
E: Unable to correct problems, you have held broken packages.
bushguy@bushguy:~$

Manfred Hampl (m-hampl) said : #4

1. The support for Ubuntu vivid has ended two months ago, see https://wiki.ubuntu.com/Releases
You should upgrade to Ubuntu 15.10 "wily" as soon as feasible. Later this month the next version 16.04 "xenial" will be published. That version will then be supported for five years.
(For the time being the repositories for vivid are still available, so this is not the reason for your problem.)

2. What is the output of the commands

uname -a
lsb_release -crid
apt-cache policy
apt-get --simulate install melt python-mlt python-mlt5 python-mlt

Manfred Hampl (m-hampl) said : #5

Oops, sorry the very last command should have been

apt-get --simulate install melt python-mlt python-mlt5 python-mlt2

deliveryman (ronjnk) said : #6

Good Morning Manfred. Thank you. The commands responses are below.

bushguy@bushguy:~$ uname -a
Linux bushguy 3.19.0-33-generic #38-Ubuntu SMP Fri Nov 6 18:18:12 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
bushguy@bushguy:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 15.04
Release: 15.04
Codename: vivid
bushguy@bushguy:~$ apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://archive.ubuntu.com/ubuntu/ vivid/universe Translation-en_CA
 500 http://archive.ubuntu.com/ubuntu/ vivid/universe Translation-en
 500 http://archive.ubuntu.com/ubuntu/ vivid/multiverse Translation-en
 500 http://archive.ubuntu.com/ubuntu/ vivid/main Translation-en_CA
 500 http://archive.ubuntu.com/ubuntu/ vivid/main Translation-en
 500 http://archive.ubuntu.com/ubuntu/ vivid/multiverse i386 Packages
     release v=15.04,o=Ubuntu,a=vivid,n=vivid,l=Ubuntu,c=multiverse
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ vivid/main i386 Packages
     release v=15.04,o=Ubuntu,a=vivid,n=vivid,l=Ubuntu,c=main
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ vivid/universe i386 Packages
     release v=15.04,o=Ubuntu,a=vivid,n=vivid,l=Ubuntu,c=universe
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ vivid/multiverse amd64 Packages
     release v=15.04,o=Ubuntu,a=vivid,n=vivid,l=Ubuntu,c=multiverse
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
     release v=15.04,o=Ubuntu,a=vivid,n=vivid,l=Ubuntu,c=main
     origin archive.ubuntu.com
 500 http://archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
     release v=15.04,o=Ubuntu,a=vivid,n=vivid,l=Ubuntu,c=universe
     origin archive.ubuntu.com
Pinned packages:
bushguy@bushguy:~$ apt-get --simulate install melt python-mlt python-mlt5 python-mlt2
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Also keep in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python-mlt5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However, the following packages replace it:
  python-mlt:i386 python-mlt

Package python-mlt2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However, the following packages replace it:
  python-mlt:i386 python-mlt

E: Package 'python-mlt5' has no installation candidate
E: Package 'python-mlt2' has no installation candidate
bushguy@bushguy:~$

Manfred Hampl (m-hampl) said : #7

Ok, what is the output of

apt-get --simulate install melt python-mlt

Remark: You have not enabled the vivid-updates and vivid-security repositories. So your system does not get any bug fixes and updates, not even for critical vulnerabilities.

deliveryman (ronjnk) said : #8

Hi Manfred,
My situation is bit unique. My wife and I are alone 100 miles in the wilderness. This computer/satellite connection is our lifeline to the outside world. I have limited bandwidth and at one time, I did have all the updates enabled. It created a pile of problems for me and I vowed as long as the system runs for my needs, I wouldn't monkey too much with it. If the updates are needed to get openshot running, I would likely wait until the next version and then download and install that. Thanks Manfred.

bushguy@bushguy:~$ apt-get --simulate install melt python-mlt
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Also keep in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 melt : Depends: libmlt6 (>= 0.9.2+git20141027) but it is not going to be installed
 python-mlt : Depends: libmlt++3 (>= 0.9.2+git20141027) but it is not going to be installed
              Depends: libmlt6 (>= 0.9.2+git20141027) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
bushguy@bushguy:~$

Manfred Hampl (m-hampl) said : #9

I understand your approach to limit the amount of data to download by disabling the updates. This, however, might have caused the dependency problem that prevents the installation of openshot.
In any case it should be possible to find a way for installing openshot without the need to do a full system update (which would require about 1 GB of download).

What is the output of

apt-cache policy melt python-mlt libmlt6 libmlt++3
apt-get --simulate install melt python-mlt libmlt6 libmlt++3

deliveryman (ronjnk) said : #10

Hello Manfred,
I really apologize for your time I'm taking on this. I'm truly appreciative that you've hung with me. I was hoping it would be a simple download of a package and we would have openshot running. Thank you! Ron

bushguy@bushguy:~$ apt-cache policy melt python-mlt libmlt6 libmlt++3
melt:
  Installed: (none)
  Candidate: 0.9.2+git20141027-1
  Version table:
     0.9.2+git20141027-1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
python-mlt:
  Installed: (none)
  Candidate: 0.9.2+git20141027-1
  Version table:
     0.9.2+git20141027-1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
libmlt6:
  Installed: (none)
  Candidate: 0.9.2+git20141027-1
  Version table:
     0.9.2+git20141027-1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
libmlt++3:
  Installed: (none)
  Candidate: 0.9.2+git20141027-1
  Version table:
     0.9.2+git20141027-1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/universe amd64 Packages
bushguy@bushguy:~$ apt-get --simulate install melt python-mlt libmlt6 libmlt++3
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Also keep in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 libmlt6 : Depends: libqt4-opengl (>= 4:4.5.3) but it is not going to be installed
           Depends: libqt4-svg (>= 4:4.5.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
bushguy@bushguy:~$

Manfred Hampl (m-hampl) said : #11

Ok, continue with the output of

apt-cache policy libqt4-opengl libqt4-svg
apt-get --simulate install melt python-mlt libmlt6 libmlt++3 libqt4-opengl libqt4-svg

deliveryman (ronjnk) said : #12

bushguy@bushguy:~$ apt-cache policy libqt4-opengl libqt4-svg
libqt4-opengl:
  Installed: (none)
  Candidate: 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6
  Version table:
     4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
libqt4-svg:
  Installed: (none)
  Candidate: 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6
  Version table:
     4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
bushguy@bushguy:~$ apt-get --simulate install melt python-mlt libmlt6 libmlt++3 libqt4-opengl libqt4-svg
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Also keep in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 libqt4-opengl : Depends: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1 is to be installed
                 Depends: libqtgui4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1 is to be installed
 libqt4-svg : Depends: libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1 is to be installed
              Depends: libqtgui4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1 is to be installed
E: Unable to correct problems, you have held broken packages.
bushguy@bushguy:~$

Manfred Hampl (m-hampl) said : #13

Ok, this now shows what the cause of the problem is. It is related to enabling and disabling the vivid-updates repository.

There are two versions for libqtgui4 and related packages:
In the "vivid" repository 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6
and in the "vivid-updates" repository 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6.1

All the related packages have to be the identical version.

Your status is, that at a certain moment in time you had the -updates repository enabled, and some packages were installed with version ...ubuntu6.1
Now openshot requires a few additional libqt* packages, and due to disabling the -updates repository, the package management system only finds the ...ubuntu6 version and refuses to install them.

I see two possibilities:

1. temporarily enable the -updates repository to allow the installation of the ...ubuntu6.1 packages
or
2. downgrade all libqt packages to the ...ubuntu6 version

deliveryman (ronjnk) said : #14

Hello Manfred,
You are an absolute genius. Wonderful job of detective work! I opt to take a chance and I'll update the system to ubuntu 6.1 Could you please walk me through the steps of exactly what should be enabled. I will go to software and updates. Going on memory, there are numerous tabs with various selections that can be checked or unchecked. I seem to remember awhile back I had to add some repositories for some other programs. What do I need at a minimum to be selected under what tab and boxes checked to assure I download what is needed? I can't thank you enough Manfred. Have a great day! Ron

Best Manfred Hampl (m-hampl) said : #15

If you do not want to install all pending updates for all packages, but just want to install openshot, you can proceed as follows:

In software and updates enable (tickmark) vivid-updates and vivid-security (in the third tab)
close this window
reload the package information
close that program.

Try the command in a terminal window

sudo apt-get install openshot

If this successfully installs openshot, then you can undo the modifications in software and updates.

Another possibility is installing all pending updates:
do the change in software and updates as above
run update-manager to download and install all updates (probably several 100 MB data to download)
and install openshot with the terminal command from above, or use software-center or similar programs.

deliveryman (ronjnk) said : #16

Outstanding Manfred! It installed fine. I am so excited to learn this program. Thank you so much again for your time and help. I wish you all the best! Ron

deliveryman (ronjnk) said : #17

Thanks Manfred Hampl, that solved my question.