which linux version do i need to use openshot? I have mint 17 64bt! thanks

Asked by misschristib on 2015-12-22

I just need to know which version of Linux, do I need in order to use/try this AWESOME OpenShot Video Editor, with??? I have a few Linux Discs but have just discovered this beautiful video editor and HAVE TO HAVE IT! Not sure which is compatible? I have Mint 17-Cinnamon 64bit, Mint 10-Julia 64 amd, Chrome O/S Linux and 2 older Ubuntu discs! Please Inform me what I need to try this! Thank you! This looks amazing!

Question information

Language:
English Edit question
Status:
Answered
For:
OpenShot Video Editor Edit question
Assignee:
No assignee Edit question
Last query:
2015-12-22
Last reply:
2015-12-29
Olivier Girard (eolinwen) said : #1

On linux you still take the last version because a new version is available every 6 mouths for the major distributions.
So then for you use Linux mint 17.2.
Good luck.

Can you help with this problem?

Provide an answer of your own, or ask misschristib for more information if necessary.

To post a message you must log in.