Openshot 1.4.3 frequently crashes on Linux Mint 17.3

Asked by Simon Hobeck on 2015-11-13

Hi, Am finding Openshot easy to learn, but it crashes on me every 2-3 minutes often with little consistency of behaviour.

The only error I receive via Terminal is "Segmentation Fault".

A previous forum suggested it was related to clicking the screen too soon after saving...but that doesn't appear to help.
Its usually when manipulating something on the track timeline, but not always - sometimes when playing a preview.

I have read various forums and the FAQs but it seeems to be a long running issue.
I have tried to update MLT (whatever that is) based on the FAQ advice.
Another forum suggested using version 1.4.4 but I can't find that to download.

Any suggestions on what I can do to fix this...i have hunted for a few hours but not finding any answers.

Question information

Language:
English Edit question
Status:
Answered
For:
OpenShot Video Editor Edit question
Assignee:
No assignee Edit question
Last query:
2015-11-13
Last reply:
2015-11-14
Olivier Girard (eolinwen) said : #1

Hi,

Great that you have search and find our faq's and our forum.
Effectively, this error is due to mlt, our actual video framework. And yes the solution is to update this one. However, you don't tell us on which distribution (and his version) you are. Checking about mlt, I've seen unfortunately that the last version available is not available for all versions of Ubuntu. And the last of mlt (i.e 0.98) is not available easily.

About the 1.44 I don't remember how to get it. This version is available on Launchpad, our actual development plateform.
Try to do that :
bzr branch lp:openshot
but it is without guaranty and check in the help menu if you get the 1.4.4.

Can you help with this problem?

Provide an answer of your own, or ask Simon Hobeck for more information if necessary.

To post a message you must log in.