I can't "end" my video.

Asked by Bob Kelly on 2012-04-08

The video is 1:52. The closest I can come is saving it at 2:00. Then when I open it, it's 3:45. How do you "end" a project?

When I "exported" it, it saved it at much longer that 1:53 as well. Any thoughts or suggestions? I've just spent 2 hours trying to figure it out, and my brain is zapped.

Question information

Language:
English Edit question
Status:
Answered
For:
OpenShot Video Editor Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-08
Last reply:
2012-11-09
Olivier Girard (eolinwen) said : #1

Hi;
I must said that I don't understand what are you saying. :-(

Tell us before which version are you using of Openshot, ffmpeg, mlt and on which system are you using too.
What give you the output when you run openshot in a console ?
Thanks.

Bob Kelly (thebobkelly) said : #2

Sorry, this is my first time trying to post something like this.

I'm using 1.4.0.

When I finished the video, it looks like the video should be 1:53. However, when I hit the red circle at the top, and it saves the project, it saves it a minute + longer.
When I "export" it, as if I were to save a version to post, it does the same thing.

I created a different project, and didn't run into this problem. So, maybe I need to just start from scratch?

Any thoughts/suggestions would be appreciated.

Olivier Girard (eolinwen) said : #3

You don't give us more explanations.

Are you on Ubuntu (if yes which version i.e Natty, Lucid, Oneiric,..), Debian, Fedora, Opensuse,........ ?

However, you should update your version of Openshot, the lat is the 1.4.2.
See here how to do that on Ubuntu : https://answers.launchpad.net/openshot/+faq/1850

What version of MLT have you ? If you are on Oneiric, the official version have a lot of regression. For sample, you can't export on DVD format. See here how to resolve that : https://answers.launchpad.net/openshot/+faq/1859
And another good link if you are on Ubuntu : How to get the last version of MLT : https://answers.launchpad.net/openshot/+faq/1861

What type of file do you use ? What type of export do you want to do ?

More you 'll give explanations, quicker your problem will be resolved and that's true for any kind of open-source project, not only for Openshot.

Karl Fogel (kfogel) said : #4

I'm also having this problem, with OpenShot 1.4.2 on Debian GNU/Linux ('testing' dist, updated at least daily). I've got my video all arranged perfectly in OpenShot. It ends at 3:52. Or rather, I *want* it to end at 3 minutes and 52 seconds... But when I play it in OpenShot, the player continues past where I want the end to be, and when I export, the result is 10 (!) minutes long, with blank (black) screen filling in the empty space.

Here are the details of the export attempt:

I ran "openshot my-finished-video.osp &" from the command line. Then I chose File->Export (does same as the red button, I assume?), and the Export control panel came up. In the Profile field, I selected "Web". This caused the other fields to automatically fill in with default values:

   Target: Flickr-HD
   Video Profile: HD 720p 25 fps
   Quality: Med

I left those defaults as they were (I don't know enough about video to change them) and hit the "Export Video" button in the lower right.

It took about 8 minutes to complete the export. The resultant file "my-finished-video.mov" was 136 MB large. When I play it with mplayer from the command line, the video lasts about 10 minutes as described above. I also tried exporting with the "YouTube" profile and its defaults, which produced a .mpeg video, but it also lasted about 10 minutes. I also tried playing them through my browser (Firefox), just to be sure, and the length was the same.

How do I tell OpenShot to end the video at 3:52 in such a way as to have that affect the export? Apparently having my last clip end at 3:52 is not enough to do it

Here's what OpenShot says when I start it up, by the way:

===========================================================================
$ openshot my-finished-video.osp &
------------------------- ERROR 1 ------------------------------
Failed to import 'from openshot import main'
Error Message: cannot import name main
----------------------------------------------------------------
--------------------------------
   OpenShot (version 1.4.2)
--------------------------------
Process no longer exists: 8392. Creating new pid lock file.
Adding files to the watch queue:

Detecting formats, codecs, and filters...
---
video_codecs:
  - a64multi
  - a64multi5
  - asv1
  - asv2
  - bmp
  - cljr
  - dnxhd
  - dpx
  - dvvideo
  - ffv1
  - ffvhuff
  - flashsv
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - jpegls
  - ljpeg
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v2
  - msmpeg4
  - pam
  - pbm
  - pcx
  - pgm
  - pgmyuv
  - png
  - ppm
  - qtrle
  - rawvideo
  - roqvideo
  - rv10
  - rv20
  - sgi
  - snow
  - svq1
  - targa
  - tiff
  - v210
  - v410
  - wmv1
  - wmv2
  - zlib
  - zmbv
  - libdirac
  - libschroedinger
  - libtheora
  - libvpx
  - libx264
  - libxvid
...
---
audio_codecs:
  - aac
  - ac3
  - ac3_fixed
  - alac
  - eac3
  - flac
  - mp2
  - nellymoser
  - real_144
  - vorbis
  - wmav1
  - wmav2
  - roq_dpcm
  - adpcm_adx
  - g722
  - g726
  - adpcm_ima_qt
  - adpcm_ima_wav
  - adpcm_ms
  - adpcm_swf
  - adpcm_yamaha
  - libgsm
  - libgsm_ms
  - libmp3lame
  - libspeex
  - libvorbis
...
---
formats:
  - a64
  - ac3
  - adts
  - adx
  - aiff
  - amr
  - asf
  - ass
  - asf_stream
  - au
  - avi
  - avm2
  - cavsvideo
  - crc
  - daud
  - dirac
  - dnxhd
  - dts
  - dv
  - eac3
  - ffm
  - ffmetadata
  - filmstrip
  - flac
  - flv
  - framecrc
  - framemd5
  - g722
  - gif
  - gxf
  - h261
  - h263
  - h264
  - image2
  - image2pipe
  - ipod
  - ivf
  - latm
  - m4v
  - md5
  - matroska
  - matroska
  - mjpeg
  - mlp
  - mmf
  - mov
  - mp2
  - mp3
  - mp4
  - mpeg
  - vcd
  - mpeg1video
  - dvd
  - svcd
  - mpeg2video
  - vob
  - mpegts
  - mpjpeg
  - mxf
  - mxf_d10
  - null
  - nut
  - ogg
  - oma
  - alaw
  - mulaw
  - f64be
  - f64le
  - f32be
  - f32le
  - s32be
  - s32le
  - s24be
  - s24le
  - s16be
  - s16le
  - s8
  - u32be
  - u32le
  - u24be
  - u24le
  - u16be
  - u16le
  - u8
  - psp
  - rawvideo
  - rm
  - RoQ
  - rso
  - rtp
  - rtsp
  - sap
  - segment
  - smjpeg
  - sox
  - spdif
  - srt
  - swf
  - 3g2
  - 3gp
  - truehd
  - rcv
  - voc
  - wav
  - webm
  - yuv4mpegpipe
  - alsa
  - oss
...
project state modified
state saved
NEW SDL CONSUMER
state saved

Karl Fogel (kfogel) said : #5

Okay, I may have found a workaround:

  http://openshotusers.com/forum/viewtopic.php?f=11&t=442#p3913

Here's what he said:

  "I created some new tracks and moved there the clips in the old ones. I deleted the old tracks and the exported video has the correct length now. It seems that something was stored in the old tracks at high timeline positions even if I couldn't see it."

I tried that solution, and it's worked so far for a YouTube-profile export to .mpeg. The next format is still exporting, but if it worked for one, I assume it'll work for them all.

FURTHER REFERENCES:

Since I spent a fair amount of time in the OpenShot user forums searching for a solution to this, here are all the posts that seemed like they might have something relevant, ending with the one above:

  Can't Get Rid of Extra Timeline at the End
  http://openshotusers.com/forum/viewtopic.php?f=11&t=442&hilit=export+end

  Export length often random
  http://openshotusers.com/forum/viewtopic.php?f=11&t=374&hilit=export+end

  Trying to get a short clip from a movie
  http://openshotusers.com/forum/viewtopic.php?f=11&t=1307&p=6164&hilit=export+end#p6164

  Video lenght shown as twice of what it really is [sic]
  http://openshotusers.com/forum/viewtopic.php?f=11&t=256&hilit=export+end

  Trim the timeline
  http://openshotusers.com/forum/viewtopic.php?f=11&t=435&hilit=export+end

  Openshot changes video on export?
  http://openshotusers.com/forum/viewtopic.php?f=11&t=595&hilit=export+end

  Need help removing dead air
  http://openshotusers.com/forum/viewtopic.php?f=11&t=734&hilit=export+end

Karl Fogel (kfogel) said : #6

Heh, sorry: s/ending with the one above/starting with the one above/.

Karl Fogel (kfogel) said : #7

Goodness I must be tired of looking at this screen. I wish there were a way to edit my comments in Launchpad Answers. Anyway, even though it's a minor and probably irrelevant correction, even #6 above is not *quite* right -- the solution that worked is actually the second one down in the list. Not that this matters, since I described the solution before that anyway. I'm going to walk away from the computer for a while. I have literally written & released entire programs in the time it took me to find a workaround for this OpenShot problem.

Can you help with this problem?

Provide an answer of your own, or ask Bob Kelly for more information if necessary.

To post a message you must log in.