OpenShot "export" says I don't have libx264 and/orlibmp3lame for just about every option. But my Synaptic Package Manager says I have two of each. I can't export my video file.

Asked by Brian Joyce on 2011-01-15

I need Open Shot for the Rotation Effect -- my 6 minute video was shot on a vertical axis. But I can't export my video file. I've been trying to follow Vimeo's compression guidelines for uploading. By the time I get to "Quality" options I get an OpenShot Error window saying I need libx264 and/or libmp3lame. I had one of each of these files already in my Synaptic Package Manager and I downloaded two more. Still I get rejected.

The raw video file from my camera is MVI_####.MOV if that helps any.

Question information

Language:
Spanish (Spain) Edit question
Status:
Solved
For:
OpenShot Video Editor Edit question
Assignee:
No assignee Edit question
Solved by:
Andy Finch
Solved:
2011-01-15
Last query:
2011-01-15
Last reply:
2011-01-15
Best Andy Finch (fincha) said : #1

Andy Finch suggests this article as an answer to your question:
FAQ #1040: “HOW TO: Install libx264 and libmp3lame”.

Thanks Andy Finch, that solved my question.

Tim Abell (tim-abell) said : #3

On ubuntu 12.04 lts the package is called libavformat-extra-53 and causes removal of libavformat53 (check the dependencies are okay before it does the removal)