Error adding new item line in Purchase Order

Asked by stone.wu

Hi all,
i inherited state in purchase.order - added Revision, Close.
the Revision state is to allow Purchase Order to revise the price or add item after approved.But what happend is i can't add new item line in this added state, it'll always prompt the below error msg.

Environment Information :
System : Windows-post2008Server-6.1.7600
OS Name : nt
Operating System Release : post2008Server
Operating System Version : 6.1.7600
Operating System Architecture : 32bit
Operating System Locale : en_US.cp1252
Python Version : 2.6.5
OpenERP-Client Version : 6.1.1
Last revision No. & ID :Bazaar Package not Found !Traceback (most recent call last):
  File "netsvc.pyo", line 489, in dispatch
  File "service\web_services.pyo", line 599, in dispatch
  File "osv\osv.pyo", line 122, in wrapper
  File "osv\osv.pyo", line 176, in execute
  File "osv\osv.pyo", line 167, in execute_cr
  File "osv\orm.pyo", line 2947, in read
  File "osv\orm.pyo", line 3070, in _read_flat
KeyError: 10340

after i researched i found out that it only happened to meet this error if we're adding a new item line beyond the state provided by the core.
i tried add in done & approve state, it allows me, but not in my revision or close state.
i wonder if there're any static rules or anything that prevent us from adding item line

Please help, i'm in urgentThx a lot in advance

Question information

English Edit question
Odoo Server (MOVED TO GITHUB) Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Serpent Consulting Services (serpent-consulting-services) said :

Would you please make sure you have not removed any account/product/purchae orders which is referred in existing record?
Other thing, If you have added the states, make sure you adjusted workflow too.

Revision history for this message
stone.wu (sutono-wu) said :

i found the reason of this error...

this is caused by different version of GTK.
i used openERP 6.0.4 server and GTK 6.1.1
then i goto test this same scenario, same addons on GTK 6.0.4, it works.

Guess it'll caused by the different version of crash memory issue.