OpenERP v7 - Critical installation

Asked by Sylvain Plante


I have submitted a bug report for this issue on november 21th and it does not seem to have been review or anything. I would like to help improve the product on the windows platform but I need at very least, to be able to install it.

I would like to know if some people have better luck at installing this on a windows server 2k3?
I have downloaded OpenERP v7 Trunk 6.2dev-20121116-000101.

I wanted to try the Ubuntu version but Ubuntu 12.04.1 fail to install in XenServer VM.

So any hint to solve the installation problem in windows? I have already upload the content of the configuration file and the log file containing error message. Reference Bug #1081829

Any answer would be greatly appreciate.


Question information

English Edit question
Odoo Server (MOVED TO GITHUB) Edit question
No assignee Edit question
Solved by:
Alexandre Fayolle - camptocamp
Last query:
Last reply:
Revision history for this message
Nhomar - Vauxoo (nhomar) said :

Sorry my friend.

Try to solve Windows problems is OpenERP is a shot in the feet for several reasons, i really recommend you use some Virtual Box or VM machine with Ubuntu or derivated and use it in Web.

Reason are a lot, but in this case IMHO if you pretend give services or even mantain a serious implementation you must use Linux.

Good Luck and I really hope you understand the point.

Revision history for this message
Sylvain Plante (sylvain-plante) said :

Hi mister Hernandez,

I have been in the consulting business for several year but I am out of it now. I want to use OpenERP for my own business.
I'm not as versed in Linux as I am in Windows. But it seem that it will be easier to learn Linux than Python and the whole programing environment.

I am still amaze that the product does not even install correctly.

Do you have a suggestion for a Linux flavor that OpenERP will run onto without too much trouble? With XenServer I have the choice between :

CentOS v6, Debian 6.0, Oracle Linux 6 or Suse Linux 11. I need a graphical interface if I want to get somewhere without pulling what left of hair on my head!

Any insight would be appreciate.


Revision history for this message
Aamir Riaz (riaz-aamir) said :


My suggestion is to use Ubuntu 12.04.1 LTS, its a Debian based linux distribution and OpenERP is also available on its repository.


Revision history for this message
Nhomar - Vauxoo (nhomar) said :

I use Ubuntu, there are a lot of how tos on line to know how install from source, and in you will have the last compiled package.


Revision history for this message
Sylvain Plante (sylvain-plante) said :

Thank you guys,

Unfortunetly, XenServer 6.1 is still not fully compatible Ubuntu 12.04.1 LTS. It crash during installation of base module. The more I work with XenServer, the more I find it temperamental. Problems are just pilling up for me. :-(

Is there any older version of Ubuntu I can use without any problem with OpenERP?

I am thinking of trying Ubuntu 11.10 server.


PS I can not get over the fact that it does not even install properly on a fresh install Windows Server 2003 with SP2. Do they try their builds sometime? Maybe it is me but please tell me where to start.

Revision history for this message
Aamir Riaz (riaz-aamir) said :

You can use Oracle VirtualBox v4.2.4, it is fully compatible with Ubuntu 12.04

Revision history for this message
Sylvain Plante (sylvain-plante) said :

Thank you Aamir.

I am using XenServer 6.1 as a Bare Metal Hypervisor. I am trying to install a flavor of Linux in a guest to run OpenERP.
I finally succeeded in installing Ubuntu 12.10 but I am having a hard time getting a graphical environment to work.

Would be much simpler if the Windows version would install or if someone from OpenERP, just give me a hint on how to achieve it.

I might have to reconsider my choice of OpenERP.

As to change the hypervisor, for now, it is not possible because I am running 6 others VM on it. It is too much work. VirtualBox is not a Bare Metal hypervisor, so I still need to install some sort of Linux system to host it.

Thank for the suggestion anyway.


Revision history for this message
Best Alexandre Fayolle - camptocamp (alexandre-fayolle-c2c) said :

See the comment I just added on : I think you need to set the USERNAME environment variable.

Revision history for this message
Sylvain Plante (sylvain-plante) said :

Thanks Alexandre Fayolle @ camptocamp, that solved my question.