dbfilter in configuration file is ignored

Asked by Sebastian J. Bronner on 2012-02-24

Version: 6.1-1-1 as packaged for ubuntu
Platform: Ubuntu Oneiric Ocelot 11.10

erp61 GA was announced yesterday. So, I eagerly installed it today, and I was delighted about the new dbfilter (using a regular expression). However, every pattern I put into the configuration file was ignored.

Thankfully, openerp is open source, so I was able to debug what was happening to my value. It was being clobbered by the default value during the check whether it had been assigned at the command line.

/usr/share/pyshared/openerp/tools/config.py line 387
"self.options[arg] = getattr(opt, arg)

The problem is in line 154. The default value is specified using "default='.*'" instead of the proper "my_default='.*'".

Cheers,
Sebastian

Question information

Language:
English Edit question
Status:
Open
For:
Odoo Server (MOVED TO GITHUB) Edit question
Assignee:
No assignee Edit question
Last query:
2012-02-24
Last reply:
2012-04-02
Amit Parik (amit-parik) said : #1

Hello Folks,

I have checked this issue, and db_filter is working fine with web interface. Might be you have used this config parameter with gtk client but it's not working with gtk.

Just go though openerp server type check the help with --help, you can seen like this.

  Web interface Configuration:
    --db-filter=REGEXP Filter listed database

So It means that db filter is only used for web interface with regular expression. I have checked this with web interface and it's working fine. Would you please check attached video.

This is not a bug that's why I am closing this issue.

Thanks for understanding!

Can you help with this problem?

Provide an answer of your own, or ask Sebastian J. Bronner for more information if necessary.

To post a message you must log in.