attrs in gtk-client does not works

Asked by Cristian Salamea on 2009-11-10

Hi,
I am defined attrs for a field in my view as follow:

                  <field name="sequence_id" attrs="{'required':[('type','=','retention')],
                                                   'invisible':[('type','!=','retention')] }"/>

In the web-client work fine appears as required but in gtk-client just required attribute works invisible dont.

Waiting for your help,

Cheers

Cristian

Question information

Language:
English Edit question
Status:
Solved
For:
Odoo GTK Client (MOVED TO GITHUB) Edit question
Assignee:
No assignee Edit question
Solved by:
Jay Vora (Serpent Consulting Services)
Solved:
2010-02-01
Last query:
2010-02-01
Last reply:
2010-02-01

Hello,

In gtk-client, In attr invisible is not done on particular field instead you can put this in group.

thanks.

Cristian Salamea (ovnicraft) said : #2

I tried in a group, invisible works, field appears readonly instead of required as i wrote in attrs.
could be a bug?

Regards,

Hello Cristian,

Group is supposed to work only with invisible attribute.

You should use the combined logic for invisible of Group and required of field.

Group is not a field which can set to be required.

You may go with the option of PAGE too.

Thank you.

Hello Cristian,

May I ask you for the status of this question?
If this is solved,would you please change the status?

Thanks.

Cristian Salamea (ovnicraft) said : #5

Thanks Jay (Open ERP), that solved my question.