export - import product with Database ID

Asked by Mecatis on 2009-09-01

Hello, when i want make a change in a product, for example in the field "Description", I export the product in .csv, i write "test" in this field, i import the csv and it's ok, the description of product in OpenERP i "test".

But when i want erase this description with a blank field, I erase "test" in the .csv, I import this csv but the description in OpenERP is always "test", is not blank.

How can I make to write a blank field ?

Question information

Language:
English Edit question
Status:
Open
For:
Odoo GTK Client (MOVED TO GITHUB) Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-28
Last reply:
2009-10-28

This question was originally filed as bug #422432.

This question was reopened

shalabh (shalabh7777) said : #1

hi,

Did you try using the "" (empty quotes) in place of "test" where you wish to put your blank field.

Shalabh

Mecatis (engineering) said : #2

Hi !

thank you for your answer.

I have trying with "" but it dosen't work. One time on excel and one time manually on the .csv fiel.

Mecatis (engineering) said : #3

Sorry : ...on the .csv file...

Hello,

Its Working and No need to Pass Blank in "". Its working in csv when you passed blank. Just Reload from client.

Thanks.

Mecatis (engineering) said : #5

Sorry, I don't understand, I have always anything in this fiel description.

I have on the .csv file :

"Database ID","Description","Name"
44,,"Varistor 275V"

I want nothing on Description, is that right with ,, ? or with ,"", ? it dosen't work, I have always test on Description...

Hello,

"Database ID","Description","Name" := This is Problem you need to write actual field name what you defined in the class not the string of this field.

I hope this will help you.

Thanks.

Mecatis (engineering) said : #7

Hello !

it's working with a space, is not a very good solution, but it's ok for Description...

Thank you !

Mecatis (engineering) said : #8

Thanks vra (openerp), that solved my question.

Mecatis (engineering) said : #9

Hi !

I think I have understand why it's not possible of erase the field "description" :

because, when I make a import with a under description, I change only the translation in French, thus the description in English remains the same !

But I don't now how to avoid it...

Mecatis (engineering) said : #10

Hi !

I think I have understand why it's not possible of erase the field "description" :

because, when I make a import with a under description, I change only the translation in French, thus the description in English remains the same !

But I don't now how to avoid it...

Hello,

Can you tell me in detail?
Did you pass description field in French through csv?

Thanks.

Mecatis (engineering) said : #12

Hi !

also with version 5.0.6, my GTK is in French.

I export a product with excel with field : Database ID / name / description (import compatible)

the product is :

Databes ID : 44
Name : varistor 275V
Description : test

In Excel I change "test" in "test 2" and I save in .csv utf-8

I import this file in OpenERP and I refresh the product, and with the flag next the field description, I see :

"test 2" in English
"test" in French...

But I want the same (test 2) in French and in English ! And I think when I type in a blank Field in "description" in excel, I have Blank in English and always "test" in French...

(It's ok with my English ? i write badly sorry... Do you speak french ? ;o)

Can you help with this problem?

Provide an answer of your own, or ask Mecatis for more information if necessary.

To post a message you must log in.