Bug in Partner Contacts->Set to default value

Asked by Stefan Frömken on 2010-04-12

Hello,

we just test OpenERP and now I find a bug:

I have a "partner" with two "partner contacts". When you click on the word "partner contact" you'll get a little context menu with two entries. I clicked on "set default". I thought this setting is for enabling this contact as the default person for current partner. So I selected my second partner contact and tried to enable this contacts "as default".

But now I have a big problem:

When I create a new partner these both contacts are set as default in my new records. When I click on "Set to default value" I get a errormessage: "An unknown error has been reported" followed by "Operation not permitted \n You can not set to the default value here". I get the same errors when I try to "set to default value" in my given record.
Then I delete these both contacts in my new record and click on "set default" to get no predefined contacts while creating new records. But when I create the next partner these both contacts are there again.

I tried many things so I think this should be a bug.

Many thanks

Stefan

Question information

Language:
English Edit question
Status:
Answered
For:
Odoo GTK Client (MOVED TO GITHUB) Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #561280.

Revision history for this message
Stefan Frömken (firma) said :
#1
Revision history for this message
Jay Vora (Serpent Consulting Services) (jayvora) said :
#2

Hello Stefan,

You probably have misunderstood the terminology.

The context menu is used for setting default value for a field when a record is being generated.

This has nothing to do with 'default' type of address for a partner.

And, are you setting one2many field(contacts) as default to each new record of partner?

Let us know more.

Thanks.

Can you help with this problem?

Provide an answer of your own, or ask Stefan Frömken for more information if necessary.

To post a message you must log in.