Error while calling ir.model.access.csv file

Asked by Deven Moga


I have generated one access csv file for my customized module. Now when i tries to install my module i am getting below error.

Error : No references to arihant_stage2.group_colormaking_manager

Stack :

Environment Information :
System : Linux-2.6.27-14-generic-i686-with-debian-lenny-sid
OS Name : posix
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid
Operating System Release : 2.6.27-14-generic
Operating System Version : #1 SMP Tue Aug 18 16:25:45 UTC 2009
Operating System Architecture : 32bit
Operating System Locale : en_IN.ISO8859-1
Python Version : 2.5.2
OpenERP-Client Version : 5.0.5-bzr
Last revision No. & ID : 988 <email address hidden>
Traceback (most recent call last):
  File "/home/deven/workspace/server/bin/", line 244, in dispatch
    result = LocalService(service_name)(method, *params)
  File "/home/deven/workspace/server/bin/", line 73, in __call__
    return getattr(self, method)(*params)
  File "/home/deven/Deven_Work/server/bin/service/", line 639, in execute
  File "/home/deven/Deven_Work/server/bin/service/", line 619, in _execute
  File "/home/deven/workspace/server/bin/wizard/", line 178, in execute
    res = self.execute_cr(cr, uid, data, state, context)
  File "/home/deven/workspace/server/bin/wizard/", line 74, in execute_cr
    action_res = action(self, cr, uid, data, context)
  File "/home/deven/workspace/server/bin/addons/base/module/wizard/", line 92, in _upgrade_module
    db, pool = pooler.restart_pool(cr.dbname, update_module=True)
  File "/home/deven/Deven_Work/server/bin/", line 62, in restart_pool
    return get_db_and_pool(db_name, force_demo, status, update_module=update_module)
  File "/home/deven/Deven_Work/server/bin/", line 40, in get_db_and_pool
    addons.load_modules(db, force_demo, status, update_module)
  File "/home/deven/Deven_Work/server/bin/addons/", line 728, in load_modules
  File "/home/deven/Deven_Work/server/bin/addons/", line 610, in load_module_graph
  File "/home/deven/Deven_Work/server/bin/tools/", line 857, in convert_csv_import
  File "/home/deven/workspace/server/bin/osv/", line 803, in import_data
    process_liness(self, datas, [], current_module, self._name, fields_def)
  File "/home/deven/workspace/server/bin/osv/", line 631, in process_liness
    id = ir_model_data_obj._get_id(cr, uid, module, xml_id)
  File "/home/deven/workspace/server/bin/tools/", line 686, in cached_result
    result2 = fn(self2, cr, *args[:self.skiparg-2], **kwargs2)
  File "/home/deven/workspace/server/bin/addons/base/ir/", line 434, in _get_id
    raise Exception('No references to %s.%s' % (module, xml_id))
Exception: No references to arihant_stage2.group_colormaking_manager

Please kindly help me to solve this error.
Waiting for the valuable reply.
Thanks in advance


Question information

English Edit question
Odoo Addons (MOVED TO GITHUB) Edit question
No assignee Edit question
Solved by:
Deven Moga
Last query:
Last reply:

This question was originally filed as bug #427172.

Revision history for this message
Deven Moga (erpsupport) said :
Revision history for this message
Christophe CHAUVET (christophe-chauvet) said :


it's not a bug, yous must declare your group in before read the ir.model.access.csv


Revision history for this message
Deven Moga (erpsupport) said :

Problem solved

Revision history for this message
ed (egeers) said :

how do you declare that?
I have a similar problem with the sale_product_multistep_configurator module

following error:
Environment Information :
System : Windows-32bit
OS Name : nt
Operating System Release :
Operating System Version : 32bit
Operating System Architecture : 32bit
Operating System Locale : nl_BE.cp1252
Python Version : 2.5.2
OpenERP-Client Version : 6.0.1
Last revision No. & ID :Bazaar Package not Found !Traceback (most recent call last):
  File "netsvc.pyo", line 489, in dispatch
  File "service\web_services.pyo", line 599, in dispatch
  File "osv\osv.pyo", line 122, in wrapper
  File "osv\osv.pyo", line 176, in execute
  File "osv\osv.pyo", line 167, in execute_cr
  File "C:\Program Files (x86)\OpenERP 6.0\Server\addons\base\module\wizard\", line 98, in upgrade_module
  File "pooler.pyo", line 60, in restart_pool
  File "pooler.pyo", line 39, in get_db_and_pool
  File "addons\__init__.pyo", line 883, in load_modules
  File "addons\__init__.pyo", line 748, in load_module_graph
  File "addons\__init__.pyo", line 635, in load_init_update_xml
  File "tools\convert.pyo", line 947, in convert_csv_import
  File "osv\orm.pyo", line 860, in import_data
  File "osv\orm.pyo", line 810, in process_liness
  File "osv\orm.pyo", line 724, in _get_id
  File "tools\misc.pyo", line 823, in cached_result
  File "C:\Program Files (x86)\OpenERP 6.0\Server\addons\base\ir\", line 602, in _get_id
ValueError: No references to sale.group_sale_user

The following is in the ir.model.access.csv file:

I noticed that the rest of the corresponding modules are like porduct_variant_multi and product_variant_configurator and that this module is --> I've chearche dthe whole day but i cannot find it anywhere.
I would try to program it myself but i'm not so good yet so thats why i pop this question. please help...

Kind regards,

Revision history for this message
Chandra L (vesper83) said :

change sale.group_sale_user to base.group_sale_salesman
it solve the problem