document ftp server doesn't bind if another service listens on e.g. 127.0.0.1:8021

Asked by jehan on 2009-08-10

Tested with server and addons 5.0.1.0.

If you install the document addon the ftp server allways binds to 0.0.0.0:8021. If you have another service listen on e.g. 127.0.0.1:8021 the ftp server seem to bind to no address. Sometimes it is necessary to let the document ftp server bind to a specific IP only. E.g. bind only to 127.0.0.1:8021 or 192.168.1.1:8021 if want ftp access only from and to localhost or in a LAN network.

To reproduce this:
- make a fresh install of openerp
- install document addon
=> 0.0.0.0:8021 is occupied by the document ftp server

- make a fresh install of openerp
- let another service listen on e.g. 127.0.0.1:8021
- install document addon
=> the only service listening on port 8021 is the one listening on 127.0.0.1:8021

Question information

Language:
English Edit question
Status:
Solved
For:
Odoo Addons (MOVED TO GITHUB) Edit question
Assignee:
No assignee Edit question
Solved by:
Jay Vora (Serpent Consulting Services)
Solved:
2009-08-12
Last query:
2009-08-12
Last reply:
2009-08-12
Harry (OpenERP) (hmo-tinyerp) said : #1

You can set another port for ftp server in openerp server configuration file.
ftp_server_port = <your port>

jehan (jens-e-hansen) said : #2

> You can set another port for ftp server in openerp server
configuration file.
> ftp_server_port = <your port>

This is interesting, I looked at the server options and haven't found
the option - maybe there should be a descriptive text if you call
openerp-server.py --help.

BTW: is there a option to change the ftp server interface also? I think
this is an important security related feature.

Harry (OpenERP) (hmo-tinyerp) said : #3

Yes. this option is not available in server options list. b'z this option is for document module. so. it is not display in 'openerp-server.py --help'

and currently , does not available option to change ftp server interface. Yes you can create blueprint for this suggestion.

Hi Harry

Can you convert this bug to a Question, it must be usefull

Regards,

Hello Jens,

Can you please close this question as solved one?

Many Thanks,
Jvo.

jehan (jens-e-hansen) said : #6

Thanks Jay (Open ERP), that solved my question.