l10n_chart_au module installation fails

Asked by Yvan Reichenbach on 2008-11-24

l10n_chart_au module installation fails

[Mon Nov 24 19:54:28 2008] INFO:init:addon:l10n_chart_au
[Mon Nov 24 19:54:28 2008] INFO:init:addon:l10n_chart_au:creating or updating database tables
[Mon Nov 24 19:54:28 2008] INFO:init:addon:l10n_chart_au:loading account_tax_code.xml
[Mon Nov 24 19:54:28 2008] INFO:init:addon:l10n_chart_au:loading account_chart.xml
[Mon Nov 24 19:54:28 2008] INFO:init:
<record id="chart0" model="account.account">
        <field name="code">0</field>
        <field name="name">Account Chart</field>

<!-- <field name="parent_id" eval="[]"/>-->
        <field name="type">view</field>

</record>
[Mon Nov 24 19:54:28 2008] ERROR:web-services:Exception in call: Traceback (most recent call last):
  File "/home/yvan/Download/ERP/openobject-server/bin/wizard/__init__.py", line 73, in execute_cr
    action_res = action(self, cr, uid, data, context)
  File "/home/yvan/Download/ERP/openobject-server/bin/addons/base/module/wizard/wizard_module_upgrade.py", line 94, in _upgrade_module
    db, pool = pooler.restart_pool(cr.dbname, update_module=True)
  File "/home/yvan/Download/ERP/openobject-server/bin/pooler.py", line 65, in restart_pool
    return get_db_and_pool(db_name, force_demo, update_module=update_module)
  File "/home/yvan/Download/ERP/openobject-server/bin/pooler.py", line 49, in get_db_and_pool
    addons.load_modules(db, force_demo, status, update_module)
  File "/home/yvan/Download/ERP/openobject-server/bin/addons/__init__.py", line 337, in load_modules
    load_module_graph(cr, graph, status, report=report)
  File "/home/yvan/Download/ERP/openobject-server/bin/addons/__init__.py", line 265, in load_module_graph
    tools.convert_xml_import(cr, m, tools.file_open(opj(m, filename)), idref, mode=mode, **kwargs)
  File "/home/yvan/Download/ERP/openobject-server/bin/tools/convert.py", line 845, in convert_xml_import
    obj.parse(xmlstr)
  File "/home/yvan/Download/ERP/openobject-server/bin/tools/convert.py", line 740, in parse
    self._tags[rec.nodeName](self.cr, rec, n)
  File "/home/yvan/Download/ERP/openobject-server/bin/tools/convert.py", line 708, in _tag_record
    id = self.pool.get('ir.model.data')._update(cr, self.uid, rec_model, self.module, res, rec_id or False, not self.isnoupdate(data_node), noupdate=self.isnoupdate(data_node), mode=self.mode )
  File "/home/yvan/Download/ERP/openobject-server/bin/addons/base/ir/ir_model.py", line 479, in _update
    res_id = model_obj.create(cr, uid, values)
  File "/home/yvan/Download/ERP/openobject-server/bin/osv/orm.py", line 2279, in create
    cr.execute('insert into "'+self._table+'" (id'+upd0+") values ("+str(id_new)+upd1+')', tuple(upd2))
  File "/home/yvan/Download/ERP/openobject-server/bin/sql_db.py", line 69, in execute
    res = self.obj.execute(sql, p)
IntegrityError: ERROR: null value in column "user_type" violates not-null constraint

insert into "account_account" (id,"currency_mode","code","name","company_id","check_history","active","type","reconcile",create_uid,create_date) values (3,'current','0','Account Chart','1','True','True','view','False',1,now())

Question information

Language:
English Edit question
Status:
Solved
For:
Odoo Addons (MOVED TO GITHUB) Edit question
Assignee:
No assignee Edit question
Solved by:
Jay Vora (Serpent Consulting Services)
Solved:
2009-01-05
Last query:
2009-01-05
Last reply:
2008-12-29
Numérigraphe (numerigraphe) said : #1

You're asking no question here, probably you should report a bug instead.
Be sure to quote the version you are using (with bazar revision n° if you use the trunk version).

Hi Yvan,

Can you check it now?

We have upgraded the module.
Thanks.

Thanks Jay (Open ERP), that solved my question.

RLJB (rodney-boyd) said : #4

Hi there

I just tried to install this module in a fresh install (of the stack) and it failed, details as follows:

Traceback (most recent call last):
  File "netsvc.pyo", line 231, in dispatch
  File "netsvc.pyo", line 74, in __call__
  File "service\web_services.pyo", line 552, in execute
  File "service\web_services.pyo", line 532, in _execute
  File "wizard\__init__.pyo", line 178, in execute
  File "wizard\__init__.pyo", line 74, in execute_cr
  File "C:\Program Files\OpenERP AllInOne\Server\addons\base\module\wizard\wizard_module_upgrade.py", line 92, in _upgrade_module
  File "pooler.pyo", line 61, in restart_pool
  File "pooler.pyo", line 40, in get_db_and_pool
  File "addons\__init__.pyo", line 715, in load_modules
  File "addons\__init__.pyo", line 616, in load_module_graph
  File "tools\convert.pyo", line 881, in convert_xml_import
  File "tools\convert.pyo", line 775, in parse
  File "tools\convert.pyo", line 743, in _tag_record
  File "C:\Program Files\OpenERP AllInOne\Server\addons\base\ir\ir_model.py", line 479, in _update
  File "osv\orm.pyo", line 2418, in create
KeyError: 'close_method'

Any suggestions to fix?

Thanks

R.

Hello RLJB,

Can you please tell me which is the latest revision no. you use?

This error should not appear in latest code.

Kindly make sure you are using everything latest.

Thanks a lot.