HTML tags <header> and <sheet> etc giving "invalid xml" error in my module

Asked by sambasivarao on 2014-05-10

I am usign "openerp version 7"
I am developing small example module to learn technical skills in openerp.
I am getting "Invalid xml error" when i am trying to use html tags <header> ,<sheet> etc.. inside openerp <form > tag. without html tags module working fine.
working code:

<record id="student_form" model="ir.ui.view">
   <field name="name">student.form</field>
   <field name="model">student</field>
   <field name="arch" type="xml">
                          <form string="student">
                                <field name="state" widget="statusbar"/>
                                <field name="name" />
    <field name="address"/>
                                <field name="gender"/>
                                <field name="school"/>
                                <field name='active' />
                          </form>
   </field>
</record>

Not working Code.
<record id="student_form" model="ir.ui.view">
   <field name="name">student.form</field>
   <field name="model">student</field>
   <field name="arch" type="xml">
                          <form string="student">
        <header>
                                <field name="state" widget="statusbar"/>
                             </header>
                                <field name="name" />
    <field name="address"/>
                                <field name="gender"/>
                                <field name="school"/>
                                <field name='active' />
                          </form>
   </field>
</record>

Question information

Language:
English Edit question
Status:
Solved
For:
Odoo Addons (MOVED TO GITHUB) Edit question
Assignee:
No assignee Edit question
Solved by:
sambasivarao
Solved:
2014-05-12
Last query:
2014-05-12
Last reply:
2014-05-10
jke-openerp (jke-openerp) said : #1

Hello,

You need to set the form in : version="7.0"
<form string="student" version="7.0">

At first view, I don't see other problems but i have no tested.

Best regards

JKE
R&D

sambasivarao (gs9783) said : #2

Thank you very much JKE
It's working perfectly.