Field seller_ids not found in browse_record

Asked by kunthar

Steps to reproduce:
1. Go to HR

2. Go to Employee and click Create

3. Every time we have this error:

OpenERP Server Error

Client Traceback (most recent call last):
  File "/opt/openerp/web/addons/web/", line 195, in dispatch
    response["result"] = method(self, **self.params)
  File "/opt/openerp/web/addons/web/controllers/", line 1078, in call_kw
    return self._call_kw(req, model, method, args, kwargs)
  File "/opt/openerp/web/addons/web/controllers/", line 1070, in _call_kw
    return getattr(req.session.model(model), method)(*args, **kwargs)
  File "/opt/openerp/web/addons/web/", line 43, in proxy
    result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw)
  File "/opt/openerp/web/addons/web/", line 31, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/opt/openerp/web/addons/web/", line 104, in send
    raise xmlrpclib.Fault(, formatted_info)

Server Traceback (most recent call last):
  File "/opt/openerp/web/addons/web/", line 90, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/opt/openerp/server/openerp/", line 289, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/server/openerp/service/", line 614, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/server/openerp/osv/", line 169, in execute_kw
    return self.execute(db, uid, obj, method, *args, **kw or {})
  File "/opt/openerp/server/openerp/osv/", line 123, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/opt/openerp/server/openerp/osv/", line 179, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/opt/openerp/server/openerp/osv/", line 166, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/opt/openerp/addons/product/", line 636, in name_get
    sellers = filter(lambda x: == partner_id, product.seller_ids)
  File "/opt/openerp/server/openerp/osv/", line 486, in __getattr__
    raise AttributeError(e)
AttributeError: 'Field seller_ids not found in browse_record(product.product, 1)'

I couldn't get the relation between employees and product???

Question information

English Edit question
Odoo Addons (MOVED TO GITHUB) Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was originally filed as bug #1111584.

Revision history for this message
kunthar (kunthar) said :

@serpent you possibly right. Could you please give me a hand which tables i should trace to see left overs for product?
btw, thank you for quick insight.

Revision history for this message
Serpent Consulting Services (serpent-consulting-services) said :

Dear Kunthar,

You should nullify the reference of product from employees!

Talking in SQL terminology, you shold run:

"update hr_employee set product_id null"

Add where clause only if you need !


Revision history for this message
kunthar (kunthar) said :

here what i did step by step:

UPDATE hr_employee
  SET product_id = CAST(NULL AS INTEGER);
UPDATE hr_employee
  SET product_id = NULL;

Still have the exact same error.
I have removed from the UI, all Employee records, except Administrator account.
Clear the cache of browser. Logout and login to reconnect orm properly.
Still have the exact same error.

Is there any table(s) to trace?

Revision history for this message
Serpent Consulting Services (serpent-consulting-services) said :


You might have set product as default I suppose.

Other way to solve it is to create a product with id=1.


Revision history for this message
kunthar (kunthar) said :

Thank you for your help.

I've tried to update product_id with an existing one but no chance with it.

Unfortunately, i had to disable items in the Human Resources tab below:
Time tracking section:
- Manage timesheets
- Allow timesheets validation by managers
- Allow invoicing based on timesheets (the sale application will be installed)
- Install attendances feature

And everything returned back to normal now.
We have to plan major update. @serpentine I will ping you when supoort needed.
Thank you again.

Revision history for this message
Serpent Consulting Services (serpent-consulting-services) said :


Nice to know that you got back to normacly.

But somehow the problem is still hidden under the carpet if I am not wrong. And this is not good for future.

Good luck for your updation plan , but do not miss to see our latest update on version 7.0