Hi, im having this error in management system openerp v7

Asked by eidna odacrem on 2014-06-07

I noticed that there is an error in claims and nonconformities under management menu when i click Send for Review button (in Analysis state), it says:

Server Traceback (most recent call last):
  File "/opt/openerp/server-7/openerp/addons/web/session.py", line 90, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/opt/openerp/server-7/openerp/netsvc.py", line 293, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/opt/openerp/server-7/openerp/service/web_services.py", line 626, in dispatch
    res = fn(db, uid, *params)
  File "/opt/openerp/server-7/openerp/osv/osv.py", line 131, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/opt/openerp/server-7/openerp/osv/osv.py", line 220, in exec_workflow
    res = self.exec_workflow_cr(cr, uid, obj, signal, *args)
  File "/opt/openerp/server-7/openerp/addons/audittrail/audittrail.py", line 520, in exec_workflow_cr
    return fct_src(cr, uid, model, method, *args, **kw)
  File "/opt/openerp/server-7/openerp/osv/osv.py", line 213, in exec_workflow_cr
    return object._workflow_signal(cr, uid, [res_id], signal)[res_id]
  File "/opt/openerp/server-7/openerp/osv/orm.py", line 3926, in _workflow_signal
    result[res_id] = wf_service.trg_validate(uid, self._name, res_id, signal, cr)
  File "/opt/openerp/server-7/openerp/workflow/wkf_service.py", line 119, in trg_validate
    res2 = instance.validate(cr, id, ident, signal)
  File "/opt/openerp/server-7/openerp/workflow/instance.py", line 43, in validate
    workitem.process(cr, witem, ident, signal, force_running, stack=stack)
  File "/opt/openerp/server-7/openerp/workflow/workitem.py", line 60, in process
    ok = _split_test(cr, workitem, activity['split_mode'], ident, signal, stack)
  File "/opt/openerp/server-7/openerp/workflow/workitem.py", line 175, in _split_test
    _join_test(cr, t[0], t[1], ident, stack)
  File "/opt/openerp/server-7/openerp/workflow/workitem.py", line 183, in _join_test
    create(cr,[activity], inst_id, ident, stack)
  File "/opt/openerp/server-7/openerp/workflow/workitem.py", line 40, in create
    process(cr, res, ident, stack=stack)
  File "/opt/openerp/server-7/openerp/workflow/workitem.py", line 52, in process
    result = _execute(cr, workitem, activity, ident, stack)
  File "/opt/openerp/server-7/openerp/workflow/workitem.py", line 106, in _execute
    returned_action = wkf_expr.execute(cr, ident, workitem, activity)
  File "/opt/openerp/server-7/openerp/workflow/wkf_expr.py", line 67, in execute
    return _eval_expr(cr, ident, workitem, activity['action'])
  File "/opt/openerp/server-7/openerp/workflow/wkf_expr.py", line 57, in _eval_expr
    ret = eval(line, env, nocopy=True)
  File "/opt/openerp/server-7/openerp/tools/safe_eval.py", line 241, in safe_eval
    return eval(test_expr(expr, _SAFE_OPCODES, mode=mode), globals_dict, locals_dict)
  File "", line 1, in <module>
  File "/opt/openerp/server-7/openerp/osv/orm.py", line 374, in function_proxy
    return attr(self._cr, self._uid, [self._id], *args, **kwargs)
  File "/opt/openerp/server-7/openerp/addons/mgmtsystem_nonconformity/mgmtsystem_nonconformity.py", line 221, in wkf_review
    raise osv.except_osv(_('Error !'), _('Analysis must be performed before submiting to approval.'))
NameError: global name 'osv' is not defined

please help me fix this...

Question information

Language:
English Edit question
Status:
Solved
For:
OpenERP Management System Edit question
Assignee:
Maxime Chambreuil (http://www.savoirfairelinux.com) Edit question
Solved by:
eidna odacrem
Solved:
2014-06-11
Last query:
2014-06-11
Last reply:
2014-06-10

Hello Eidna,

Can you please upgrade your management systems modules ? It should fix the problem.

Have a great day.

Maxime

eidna odacrem (andie-serador) said : #2

So i will download again the management system here to upgrade it? is that what you mean?

eidna odacrem (andie-serador) said : #3

If yes, it still has an error. Same error.

I don't think you have the latest version.

Your error message refers to line 221 of mgmtsystem_nonconformity.py in wkf_review.

The line 221 on the latest version is empty :
http://bazaar.launchpad.net/~openerp-mgmtsystem-core-editors/openerp-mgmtsystem/7.0/view/head:/mgmtsystem_nonconformity/mgmtsystem_nonconformity.py#L221

Please remove the module directory :
/opt/openerp/server-7/openerp/addons/mgmtsystem_nonconformity

download the module from Apps :
https://www.odoo.com/apps/7.0/mgmtsystem_nonconformity/

and unzip it in :
/opt/openerp/server-7/openerp/addons/

eidna odacrem (andie-serador) said : #5

Thanks!