Onboard opens on the wrong workspace?

Asked by Roger E Critchlow Jr on 2009-04-02

Hello, I've been fussing with onboard to enable passwords in tablet configuration on my laptop. I have some thoughts about the gnome-screensaver issue that I'll add to an already open question.

I noticed that when I went to a clean workspace, opened synaptic, and then tried to open onboard from the system tray to fill in the gksu login dialog, that onboard was opening on another workspace. I could see its silhouette in the workspace selector, opening, closing, but never where I needed it to fill in the password.

This seemed suboptimal, so I added the following three lines in /usr/share/pyshared/Onboard/OnboardGtk.py:

        self.window.hidden = False
+ self.window.stick() # show in all workspaces
+ self.window.set_skip_pager_hint(True) # don't show window in pager
+ self.window.set_skip_taskbar_hint(True) # don't show window in taskbar

        self.window.show_all()

which seems to be an improvement. Any feelings about this?

-- rec --

Question information

Language:
English Edit question
Status:
Answered
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2009-04-02
Last reply:
2011-12-14
Francesco Fumanti (frafu) said : #1

At least, it seems to be a work around. (I did not verify it yet)

I don't know for the moment if there could be a better solution; let's see what Chris, the main developer of onboard, thinks about it.

Thanks

Francesco Fumanti (frafu) said : #2

Onboard now has a "Always show on visible workspace" option that should solve the issue about Onboard not appearing on the visible workspace.

Can you help with this problem?

Provide an answer of your own, or ask Roger E Critchlow Jr for more information if necessary.

To post a message you must log in.