accents don't work unless I first use non-accent

Asked by Ludovic Celle on 2017-10-07

I just discovered Onboard and love it, just what I need everyday !
But I notice what might be a bug :
if I want to put a letter with accent, this one will not work unless I first use the non-accent version of the letter.
For instance, if I want to put a " ñ ", I first have to put a "n" or whatever non-accent letter...
This is very unconvenient because it requires later removing the non necessary letter put before, or at least make the accents letters not accessible from the very start of the use of Onboard...
Is that normal ?
Thanks !

Question information

English Edit question
Onboard Edit question
No assignee Edit question
Last query:
Last reply:
Francesco Fumanti (frafu) said : #1

Your description does not correspond to how Onboard should behave. Normally, you should for example click the n key on the keyboard and not release it until the the popup with the accentuated letters appear. At this point you continue to keep the mousebutton down and glide with the pointer to the accentuated character that you want to type. Once the pointer is over the accentuated letter, you can release the mouse button.

Unfortunately, you did not describe in detail how you are trying to write the accentuated letters.

Can you confirm that you are doing it the way I discribed above? If so, you have probably found a bug.

Ludovic Celle (ludovic-celle) said : #2

Hi Francesco !
Glad to read your quick answer !
I confirm I use OnBoard correctly, pressing the letter until accents pop up and I can select mine. Just as you say.
I confirm accents don't work (don't appear in my text area) at first try. They accept working only if I first pressed a non-accent letter first, like a warm up, very weird..
So, yes, as it is, it looks like a bug.
In preferences, I saw nothing about such behaviour.

Francesco Fumanti (frafu) said : #3

Hi Ludovic,

I am not able to reproduce your problem here on Ubuntu 17.04.

Could you tell us, what linux distribution, what desktop environment, etc. you are using with the corresponding version information.

Thanks in advance.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.