is qtatspi-plugin still required for plasma5

Asked by Zen25000 on 2017-07-26

Is qtatspi plugin still required for anything in onboard e.g. for plasma 5, or was it only relevant to KDE4?

In Mageia the qtatspi-plugin package was obsoleted when we moved to plasma5, but I am not sure how this may have affected onboard, so some guidance would be appreciated.

Thanks,
Barry (onboard maintainer for Mageia)

Question information

Language:
English Edit question
Status:
Answered
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2017-07-26
Last reply:
2017-07-27
marmuta (marmuta) said : #1

Hi Barry,
it seems qt-at-spi (libqspiaccessiblebridge.so) is still needed for qt4 applications. Synergy for example becomes invisible to Onboard when qt-at-spi is uninstalled, I just tried.

There's a long list of qt4 applications in Ubuntu 17.10. I suspect the situation is similar for Mageia. If there is no replacement, dropping qt-at-spi would appear to be quite a loss for accessibility in general, not just Onboard. Here it's still installed by default too, i.e. it's still a dependency of ubuntu-desktop.

Can you help with this problem?

Provide an answer of your own, or ask Zen25000 for more information if necessary.

To post a message you must log in.