International KeyProblem

Asked by Julian on 2017-07-04

Hi Community,
I have a question.
Is there a way, to disable the long press behavior of the Keys?
Cause I don't want the international Keys and I don't want the Key repeat.

Maybe someone have some suggesstions.

Best regards,
Husky

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
Julian
Solved:
2017-07-07
Last query:
2017-07-07
Last reply:
2017-07-06
Francesco Fumanti (frafu) said : #1

Hi,

Thanks for your interest in Onboard.

You should be able to achieve what you are looking for by doing the following to steps:

- Set Onboard to key-repeat. You can do it by opening the Preferences dialog of Onboard, switch to the "Keyboard" section on the left of the dialog, choose the "Advanced" tab, where you can see the "Long press action" setting. Set it to "key-repeat".

- Disable the key repeat behaviour in the system. To do so, you can open the "System Settings" dialog in Ubuntu (top right corner of the screen), choose the "Keyboard" panel and switch to the "Typing" tab. There is a checkbox in the tab to disable the key-repeat of the system, which will also disable it for Onboard.

Hoping to have been helpful.

Have a nice day.

Julian (7husky) said : #2

Hi,
I tested it but it didn't solve my Problem.
My Problem is that when I activate key-repeat in Onboard Settings, and I type a combination with dead Keys every letter is uppercase, without pressing shift.

So my new Question, is there a way only disable the Popup for international Characters?
I had a look in the source code, and Layouts but I didn't find anywhere the source for the Popup.

Best regards,
Husky

Francesco Fumanti (frafu) said : #3

I am not able to reproduce the problem here on my Ubuntu installation. (e.g. รข written with Onboard by using ^ as dead key)

Could you please tell us what distribution, Onboard version, layout and keyboard language you are using?

Julian (7husky) said : #4

Hi,

The Problem is that I use onboard in my Application.
And only here the Problem occurs. On Browser etc. it works correctly.
But I have to write the Application with mono framework :(
And here it comes to this mysterious behavior.

My Keyboard Language I set with fcitx. But the Problem occurs with all Layouts with dead Keys.
But this isn't the problem, cause it Only occurs with mono applications.

So the Problem is not on the Side from Onboard. The Keyboard is really great. The Problem is on mono side.
Also the international Key Popup makes Problems with Mono.
So i have to disable the Popup. Is there any way to get to this result?

Best regards,
Husky

Francesco Fumanti (frafu) said : #5

Hi,

I created a bug hinting at the incompatibility to the Mono framework:
https://bugs.launchpad.net/onboard/+bug/1702678

I don't know, if anything can be done about it from Onboard's side. If marmuta has an idea, he will probably add a comment. In the meantime, you might work around the problem by typing into an editor like gedit and copy/paste it to the Mono framework.

Sorry for not being able to give you a real solution and thanks for the kinds words about Onboard.

Have a nice day.

Francesco

marmuta (marmuta) said : #6

The long-press delay is adjustable in gsettings. You could set it to something high like
gsettings set org.onboard.keyboard long-press-delay 3600
and would have to wait an hour for the popup.

To get back to the default, run
gsettings reset org.onboard.keyboard long-press-delay

Julian (7husky) said : #7

Hi,
Thanks you are the best :) it works :)

Best regards,
Husky