Shift problem

Asked by Julian on 2017-01-27

Hi,
I have a problem with onboard in my Application.
I use the Layout Phone and characters like "/" "&" "%" doesn't work. It print "7""6""5".
If I active Capslock before I change the Layer it works. But then the numbers didn't work.
So now my Question, is it possible to configure the Layout, so that if I press "/" it uses automatically Capslock but if I hit the numbers it doesn't activate Capslock?

Best regards,
Julian

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
Julian
Solved:
2017-01-31
Last query:
2017-01-31
Last reply:
2017-01-27
marmuta (marmuta) said : #1

What distribution is this and what version of Onboard do you use? I'm asking because 1.3 had significantly changed how key presses are generated, mainly because of issues with Small and Phone layouts.

Julian (7husky) said : #2

Hi,
I'm using ubuntu 14.04 with LXDE. And Onboard 1.3.
It works in Browser correctly but in mono not. It seems like shift will not recognize. With caps it works. I think on Phone layout charakter like "/,(,)" are linked as number+shift. Can I symply changed this to number+caps?
Best regards,
Julian

marmuta (marmuta) said : #3

> It works in Browser correctly but in mono not.
Is this a mono application that embeds Onboard? I don't know much about mono, Is it using the system-wide xkb keymap (setxkbmap -print) or does it do things differently?

The modifiers come straight from xkb, i.e. the currently active keymap and group. There's no easy way to influence that from Onboard, unless you patch the source. For testing purposes you could look at Keyboard.py, KeySynthVirtkey.press_keysym() and switch the shift bit in mod_mask to a caps bit ( Modifiers.SHIFT -> Modifiers.CAPS).

Also perhaps run "xmodmap -pke" from mono and see if and how it is different than running it from the terminal.

If you can, testing on Ubuntu 16.04 could help too. Does the problem still exist there?

Julian (7husky) said : #4

I get it work!
I changed in settings, that shift locked and then I customized a Layout.
Thanks :)

marmuta (marmuta) said : #5

Did you replace the "/,(,)" keys in your layout? Did you switch them from char to keycode?

Julian (7husky) said : #6

Yes I replaced the Symbols and Numbers with the Keys from Compact Layout.