Onboard on Fedora

Asked by Ventilatorr on 2016-02-04

I'm trying to install Onboard on Fedora 23, but I keep running into problems. I followed the python3 instructions here https://answers.launchpad.net/onboard/+question/221655

setup.py returns:

found dconf version 0.24.0
setup.py: pkg-config returned exit code 1
setup.py: sdist needs libgtk-3-dev, libxtst-dev, libxkbfile-dev, libdconf-dev, libcanberra-dev and libhunspell-dev

I hope someone can help

Question information

Language:
English Edit question
Status:
Answered
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2016-02-04
Last reply:
2016-02-04
marmuta (marmuta) said : #1

You're still missing dependencies. Post #10 in
https://answers.launchpad.net/onboard/+question/221655
is the closest I have to a recipe for Fedora, unfortunately. It's probably outdated a by now, though. You would have to figure out the missing packages from debian/control, or simple from the error messages you get.

> setup.py: sdist needs libgtk-3-dev, libxtst-dev, libxkbfile-dev, libdconf-dev, libcanberra-dev
> and libhunspell-dev
Look at the "-dev" package names and try to figure out the corresponding package names on Fedora. Then install these. Some might simply end in -devel instead of -dev, bur others might have slightly different names or multiple might be stuck together in one single package. It's a bit of trial and error, but probably not too hard to do.

If I had more time I would install Fedora here and figure it out for you, but we're a bit under pressure to get a release out in the next two weeks. Sorry about that.

Ventilatorr (jeroen251) said : #2

I got it to work by installing packages and help from here: https://www.reddit.com/r/Fedora/comments/1yafli/how_to_get_onboard_onscreen_keyboard_working_in/

I can't get the text prediction to work yet. I have a log of the output here: http://pastebin.com/9WB3mmuB

This line:
22:25:14.996 WARNING Onboard.WPEngine: Failed to find language models in '/home/jer/.local/share/onboard/models': Bestand of map bestaat niet (2)

"Bestand of map bestaat niet" is dutch for file not found. The file doesn't exist so it's right but how do I get the file?

Ventilatorr (jeroen251) said : #3

The files showed up, I don't know why.

Some other issues, I can't get it to start on boot. The option to start in the background is greyed out. Also it won't launch on the login screen.

I followed your advice from: https://answers.launchpad.net/onboard/+question/284488 but that didn't work.

I enabled the Fedora keyboard on login so it's only a minor inconvenience.

marmuta (marmuta) said : #4

The warnings from your pastbin are benign, but most should go away with the latest Onboard from trunk.
bzr branch lp:onboard
cd onboard
./setup.py build

"Failed to find language models" in /home is harmless too and should only happen the first time you select a new language. After a while auto-save will create those files.

> I can't get the text prediction to work yet.
If gnome-shell's default keyboard shows up for gnome-terminal, gedit, etc., then auto-show and word suggestions should work in Onboard too. On Debian derivatives we usually suggest to install
libgail-common libatk-adaptor qt-at-spi libreoffice-gtk libreoffice-gtk3
and
libatk-wrapper-java
if you need Java support.
That should make it work with a few more applications, like libreoffice, Firefox, etc. Again, I don't have Fedora packages, unfortunately.

> The option to start in the background is greyed out.
Only if auto-show above it is enabled.

> Also it won't launch on the login screen.
If you use GDM as display manager then I don't have a solution yet. It used to start up fine there in the past, but apparently something changed.

Can you help with this problem?

Provide an answer of your own, or ask Ventilatorr for more information if necessary.

To post a message you must log in.