Prediction doesnt work

Asked by Bart van Lieshout on 2014-12-17

i build and installed with python3.3 also as sudo.

Prediction doesnt work so i tried to change prediction language, but then:

2014-12-17 00:27:38,365:WARNING:Onboard.WPEngine: Failed to find language models in '/home/bart/.local/share/onboard/models': Bestand of map bestaat niet (2)

Question information

English Edit question
Onboard Edit question
No assignee Edit question
Last query:
Last reply:
marmuta (marmuta) said : #1

I don't believe that warning is the reason. It just means that either the user model directory or the user language model for the language you selected doesn't exist yet. This is expected to happen the first time you use a new language. Both should eventually be created when auto-saving after 10mins happens or on exit, though only when the model was modified, i.e. you actually typed something with learning enabled.

Independent of that, you ought to get suggestions from the system language models. Those should be installed in /usr/share/onboard/models/.

Perhaps run
onboard -ddebug
Right at the end there should be something like
Loading language model '/usr/share/onboard/models/en_US.lm'
Loading language model '/home/user/.local/share/onboard/models/en_US.lm'
and no errors nearby.

More likely though, AT-SPI isn't set up correctly. Check if auto-show works first (Preferences->General->Auto show when..."). Best with some text entries from a Gtk-3 application, gedit, gnome-terminal for example. There's debug output too when you run
onboard -d atspi
There should be lines with
... AT-SPI focus event: ...
If not let me know.

What's your main desktop environment?

Thnx for looking into it. I´m using KDE. As test i installed gedit, prediction works perfect!

^Cbart@gentoo-vm /usr/src/linux-3.16.5-gentoo $ onboard -d atspi
Traceback (most recent call last):
  File "/usr/bin/onboard", line 15, in <module>
    from Onboard.OnboardGtk import OnboardGtk as Onboard
  File "/usr/lib64/python3.3/site-packages/Onboard/", line 25, in <module>
    from Onboard.KbdWindow import KbdWindow, KbdPlugWindow
  File "/usr/lib64/python3.3/site-packages/Onboard/", line 9, in <module>
    from Onboard.WindowUtils import Orientation, WindowRectPersist, \
  File "/usr/lib64/python3.3/site-packages/Onboard/", line 23, in <module>
    config = Config()
  File "/usr/lib64/python3.3/site-packages/Onboard/", line 180, in __new__
  File "/usr/lib64/python3.3/site-packages/Onboard/", line 243, in construct
    log_params["level"] = getattr(logging, options.debug.upper())
AttributeError: 'module' object has no attribute 'ATSPI'
bart@gentoo-vm /usr/src/linux-3.16.5-gentoo $

It doesnt work in chromium, which i use for e-mail and facebook chat to communicate. Is onboard depending on gnome?

marmuta (marmuta) said : #3

Oh, I assumed you're running the latest from trunk. V1.0.0 doesn't know -d atspi yet. -d debug should print AT-SPI lines in that case.

Onboard needs Gtk to function but AT-SPI is supposed to be cross-toolkit. There are bridges of varying levels of completeness for Qt/KDE, Java, libreoffice and Firefox, but honestly it works best with Gtk-3 widgets.

On Debian derivatives the packages you want are
libgail-common libatk-adaptor qt-at-spi libreoffice-gtk libreoffice-gtk3
if you need Java support.

Chromium comes with its own widget toolkit and last I checked doesn't support AT-SPI very well, if at all. It came up in questions before, but as of now, I'm not aware of any way to get word suggestions or even auto-show to work there.

Firefox should do rather well though.

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

marmuta (marmuta) said : #5

Marking answered. If you need more help let us know.

Can you help with this problem?

Provide an answer of your own, or ask Bart van Lieshout for more information if necessary.

To post a message you must log in.