Is it possible to turn off auto repositioning of onboard keyboard?

Asked by Erik Starb├Ąck on 2014-12-12

Hi!

I am building a kiosk application with fullscreen firefox, and I don't want the onboard keyboard to move if the text field happens to be "under the keyboard". I prioritize to have the keyboard in a fixed place (maybe together with some opaque feature).

I can't use the "docking -> dock to screen edge" because then the fullscreen firefox hides the keyboard. So I use "Floating windows option -> show windows on top".

I solved it with one line patching of get_repositioned_window_rect() in AutoShow.py to just "return None", but I hoped it could be possible to add a config option or something...

Thanks!

/Erik S

Question information

Language:
English Edit question
Status:
Answered
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2014-12-12
Last reply:
2014-12-13
marmuta (marmuta) said : #1

Right, there's no nice way to disable auto-positioning. You could tell the keyboard to stay impossible large distances away from widgets and have it give up moving that way.
gsettings set org.onboard.auto-show widget-clearance "(10000.0, 10000.0, 25.0, 40.0)"

That would work, but I agree, some kind of toggle would be better. Let me add something.

marmuta (marmuta) said : #2

OK, I've added a new gsettings key. You can turn off repositioning with gconf-editor or from command line:
gsettings set org.onboard.auto-show reposition-method none

Enable repositioning again with
gsettings reset org.onboard.auto-show reposition-method

I haven't added the setting to preferences yet, but might at a later point if there is more interest. You've been the first one to ask.

marmuta (marmuta) said : #3

> You can turn off repositioning with gconf-editor or from command line:
That would be dconf-editor, not gconf-editor.

Can you help with this problem?

Provide an answer of your own, or ask Erik Starb├Ąck for more information if necessary.

To post a message you must log in.