How do I build this project?

Asked by shravan kulkarni on 2013-04-12

Hi. I'm new to open source world. Please provide some pointers about building this project .

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
shravan kulkarni
Solved:
2013-04-16
Last query:
2013-04-16
Last reply:
2013-04-12

 im using Ubuntu 12.10. for past one hour im trying to build the project by
$python3 setup.py build

it reported me of some unmet dependancies and ive installed a lot of them. now im stuck with 'dconf'. please help me out. i dont know if im moving in right direction.

hi.. after installing so many libraries, i got to build the project.

but $./onboard gives me this error.

ERROR:Config: gsettings schema for 'org.onboard.typing-assistance.word-suggestions' is not installed

how do i get past this. please help me out.

Francesco Fumanti (frafu) said : #3

Hi,

Thanks for your interest in Onboard.

Did you install the gschemas.xml file from the Data directory of the source into the XDG_DATA_DIRS (on Ubuntu it is /usr/share/glib-2.0/schemas/ and compile it with the glib-compile-schemas command? This might solve your problem.

By the way, for Ubuntu, you can find more recent versions of Onboard in our PPAs.

Cheers

Francesco Fumanti (frafu) said : #4

You can find our PPAs (Personal Package Archives), with Onboard packages ready to install on this page:
https://launchpad.net/~onboard

marmuta (marmuta) said : #5

Shravan, on Ubuntu we recommend to build and install the deb package the first time. This will take care of installing the gsettings schemas.

For Ubuntu 12.10 in you may need a newer version of python3-virtkey first:

sudo apt-get build-dep python3-virtkey
bzr branch lp:virtkey
cd virtkey
debuld binary
sudo dpkg -i ../*virtkey*.deb

Then build and install Onboard:

sudo apt-get build-dep onboard
bzr branch lp:onboard
cd onboard
debuild binary
sudo dpkg -i ../onboard*.deb

marmuta (marmuta) said : #6

@Francesco, AFAIK there is no recent version for x86 in our PPAs, only for ARM. If you can, maybe add one to snapshots.

Francesco Fumanti (frafu) said : #7

@marmuta

I assumed that the ARM enabled PPA does not build exclusively for the ARM and this seems to be the case as it contains a deb for the i386 architecture and a deb for the amd64 architecture. But I don't see a deb for the ARM. Could you tell me whether the ARM enabled PPA offers packages also for the ARM?

marmuta (marmuta) said : #8

I see, so there are indeed x86 packages in ppa:onboard/ppa, but none for ARM. I get nothing later than 0.99.0~alpha1~tr1190-0ubuntu1 on the Nexus 7.

sorry guys. Dint get time over the weekend to work these things.
@frafu
i placed gchema.kml in the path u specified and compiled it as you said. It solved the problem. i was able to build and install.. but
$./onboard gives me this error.

AttributeError: 'virtkey' object has no attribute 'get_current_group'

so as @marmuta suggested i installed virtkey and tried running... its working!!

thanks a lot guys. hope i will be able to contribute anything to this project.

Boris Burkov (vasjaforutube) said : #10

Hey, guys! I've successfuly built the latest onBoard on Debian7 and want to say thanks to you. Aren't you planning to maintain a package on Debian?

I've also spotted several bugs of various "annoyingness" in
 0.99.0-alpha1-tr1190

E.g. keyboard permanently shows caps-locked state, while not being in it and gets stuck there.

Also, in custom themeing the keyboard tends to forget about "border" setting between reloads.

And numeric keyboard doesn't seem to work.

Nonetheless, thanks for your great work!

marmuta (marmuta) said : #11

Hi, good to hear you like it and thanks for the feedback. We've been asked to maintain a package in Debian, I'm for it, but it's not clear if/when/how it will happen.

1) I haven't managed to get Caps stuck here. Does Onboard's Caps key toggle when you press Caps on a hardware keyboard? Would you mind opening a bug report for this?

2) Saving the key border was broken, thanks for spotting this. I've pushed a fix.

3) Numeric keyboard seems to work here.
Can you confirm the latest python3-virtkey is installed?
$ apt-cache policy python3-virtkey
Anything >=0.63.0 should give you a working NumLock key and number pad.

Boris Burkov (vasjaforutube) said : #12

Hi, Marmuta! Thanks for reply, hope you cooperate with Debian guys anytime soon, onBoard is really sick, while Debian's default caribou-antler is quite dull.

1) I've left a bug report: https://bugs.launchpad.net/onboard/+bug/1207503. Actually, it's Shift, rather than Caps lock problem.
2) quick fix, thanks!
3) numeric keyboard confuses labels like it was with shift in (1). It shows digit labels, while interpreting presses on them as arrow keys and home/end/pgup/pgdwn. When I toggle num lock it shows arrow+home/end/pgup/pgdwn labels, but enters digits :)

virtkey-0.63.0 is actually manually installed from source tarball with (excerpt from `history`):

  198 sudo tar -zxvf virtkey-0.63.0.tar.gz
   ...
  200 cd virtkey-0.63.0/
   ... (apt-getting dependecies here)
  220 sudo python3 setup.py build
  221 sudo python3 setup.py install

marmuta (marmuta) said : #13

For anyone trying to build Onboard with instructions from this thread: python-virtkey is no longer a dependency of Onboard. You can skip building and installing virtkey, though there is no harm in keeping it installed.

Building and installing the development version of Onboard:

sudo apt-get build-dep onboard
bzr branch lp:onboard
cd onboard
debuild binary
sudo dpkg -i ../onboard*.deb