'ñ' key in phone and small distributions

Asked by David López on 2013-04-03

I use onboard 1507 trunk in archlinux with lxde and openbox. and my locale is es_ES.UTF-8.

The 'ñ' key does appear in full and compact, but it doesn't in phone and small distributions, I have to invocate it with: Ctrl+Shift+u 00f1 Ctrl+Shift+u. Is it a bug? Is there a way to include it on small and phone distributions?

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
marmuta
Solved:
2013-04-03
Last query:
2013-04-03
Last reply:
2013-04-03
Best marmuta (marmuta) said : #1

Hi David, that character should be in the long press popup of the "n"-key. Press the key down for half a second and you should get a choice of ns with various diacritics (still too many, actually). This should work in all layouts.

Sorry marmuta, but long pressing the 'n' key I don't receive choices, only 'nnnnnnnnnnnnnnn', tested in all distributions. Is there some option in preferences to hide the 'choices'? Maybe I modified it and now I can' remember.

marmuta (marmuta) said : #3

Yes, there is a toggle. It was visible in preferences in an earlier version, but I have since hidden it because it doesn't work well with the new layouts anymore, as you discovered.

gsettings reset org.onboard.keyboard default-key-action

The trade-off is that many keys won't repeat anymore in this mode. That was the price to pay for having popups on long-press.

That has sense, surely I modified defaul-key-action to single-stroke and I forgot.

Thanks marmuta, that solved my question.