Separate icon does not show up anymore

Asked by Lehmann on 2013-03-27

Working on Lubuntu, I've been helped previously to ensure that the separate onboard icon remains on top. Unfortunately, after I think applying the last patches, it doesn't work anymore: the icon on the taskbar is there, onboard shows up when you select so on the menu raised by klicking on the taskbar icon, but there is no icon on the desktop anymore! Since I use Chromium in kiosk mode, this is an issue for me.

Do you have an idea into which direction I should look to solve this problem?
Best regards,

André Lehmann

Question information

English Edit question
Onboard Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Best marmuta (marmuta) said : #1

Hi, thanks for your question.

I've just tried it with the current development version and it seemed to still work, i.e. the floating icon is visible on top of chromium in kiosk mode. Make sure you have these settings enabled.

Preferences->General->Show floating icon
Preferences->Window->Force to top

What version of Onboard and what distribution are you using?

Lehmann (andre-lehmann) said : #2


Thanks a lot for checking my problem.
The settings were enabled, so this is not the issue.
My system:
lubuntu: 12.04 with latest updates,
onboard: 0.97.0-0ubuntu4,
python-gi-cairo: 3.2.2-1~precise,
libatk-adaptor : 2.4.0-1ubuntu2

Should I get another version of one of these?

Thanks again for your great feedback.

marmuta (marmuta) said : #3

Yes, an updated Onboard would probably help. There was a related fix starting with 0.98.1, see

You can get a newer version for Precise from our PPA here:

0.99.0-alpha1 was an intermediate "emergency" release, but it should work alright. Current trunk is in better shape, but there is no x86 version in a PPA available yet. Let me know if you run into any problems.

Lehmann (andre-lehmann) said : #4

Thanks for pointing on the last versions of onboard, not available in my synaptic manager.
Unfortunately, when trying to install the 0.98.2 version, it complains that python3 (>= 3.2.3-3~) is not installed, because I have installed only the latest python3 available through the ppa: 3.2.3-0.
Similar issue when tryping to install 0.99, as it complains then that python-virtkey is not available in 0.63 version -- I have 0.60
Is it possible to install the 0.98.2 onboard version without the python 3.2.3-3 requirement?
Thanks again for your help.

marmuta (marmuta) said : #5

I'm not sure why 0.98.2 thinks it needs python3 (>= 3.2.3-3~), IIRC we only ever required >=3.2. Francesco will be back from holiday soon, he'll probably want to have a look at this.

Meanwhile, for Onboard 0.99, you can get virtkey 0.63 for Precise from here:

Lehmann (andre-lehmann) said : #6

Thanks for the virtkey link.
Now I get the onboard icon on the status bar at the bottom right of the screen, but still no floating icon.

marmuta (marmuta) said : #7

No floating icon at all or none in chromium kiosk mode?

It might be out of view, perhaps try
gsettings reset-recursively org.onboard.icon-palette
gsettings set org.onboard.icon-palette in-use true

Lehmann (andre-lehmann) said : #8

Yahoo! Thank you so much -- it was indeed just out of view!
Much appreciated your patience and very knowlegable feedbacks!
Have a great day,

Lehmann (andre-lehmann) said : #9

Thanks marmuta, that solved my question.