Black screen on lubuntu

Asked by Lehmann on 2013-02-27

Hello,

After instaling Onboard on lubuntu 12.04, Onboard doesn't work. After two tries to launch it, I get a black keyboard (e.g. like a full black panel). If I hit in the approximate location of a key, it responds. But that's not very 'user-friendly'!
On top of that, all the great features of onboard don't work: automatic show-up when entering an input field, icon doesn't show.
Perhaps a language issue -- I'm using swiss-french keyboard?

Thanks in advance for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
marmuta
Solved:
2013-02-28
Last query:
2013-02-28
Last reply:
2013-02-27
marmuta (marmuta) said : #1

Hi, thanks for the question.
This one sounds similar to a previous issue. Have a look at
https://answers.launchpad.net/onboard/+question/195106
Keys haven't been drawn at all back then, though. Your problem might still have a different cause.

For now try this:
sudo apt-get install python-gi-cairo libatk-adaptor

and let us know how it goes.

Lehmann (andre-lehmann) said : #2

Hi,

Thanks a lot for your very valuable feedback. It works for the most part!!
The only things I'm missing are two:
1. The automatic show-up doesn't work;
2. The icon is hidden when I use chrome in kiosk mode -- and if I force onboard to show, it shows all the time the full keyboard -- which is not optinal either.
Any other suggestion?

Thanks again.

Sincerely,

André Lehmann

----- Mail original -----
De: "marmuta" <email address hidden>
À: "andre lehmann" <email address hidden>
Envoyé: Mercredi 27 Février 2013 16:25:59
Objet: Re: [Question #222939]: Black screen on lubuntu

Your question #222939 on Onboard changed:
https://answers.launchpad.net/onboard/+question/222939

    Status: Open => Answered

marmuta proposed the following answer:
Hi, thanks for the question.
This one sounds similar to a previous issue. Have a look at
https://answers.launchpad.net/onboard/+question/195106
Keys haven't been drawn at all back then, though. Your problem might still have a different cause.

For now try this:
sudo apt-get install python-gi-cairo libatk-adaptor

and let us know how it goes.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/onboard/+question/222939/+confirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/onboard/+question/222939

You received this question notification because you asked the question.

Best marmuta (marmuta) said : #3

1) You may still need to
echo GTK_MODULES=atk-bridge | sudo tee -a /etc/environment
I'm not completely sure. This isn't necessary anymore in later Ubuntu versions at least.

Also, IIRC chromium doesn't support gnome accessibility well, if at all. See my post here
https://bugs.launchpad.net/onboard/+bug/936310/comments/9
Auto-show requires at least rudimentary accessibility support. Firefox and other browsers do much better.

2) Does the icon show when Preferences->Window->Force to top is enabled?

Lehmann (andre-lehmann) said : #4

Thanks again for the quick feedback.

I've run your 1) suggestion.
Now at least the icon remains (even in chrome kiosk mode) when Force on top is enabled, so that I can kick the keyboard to show up. The only problem is that now the frame doesn't show, so it is not possible to move the keyboard, depending on the location of the input text. But it's functional for the most part.
Thank you!

Lehmann (andre-lehmann) said : #5

Correction: I did not see the move button on the right! Everything OK!