How can I hide config button, for kiosk porpouse

Asked by Aldo Ortega on 2013-01-03

We are using Firefox with Rkiosk Addon, perfectly working on our kiosk, we add a touch panel and remove phisical keyboard from it, and no wwe want to use Onboard on.screen keyboard as our keyboard for the kiosk.

It work perfect, with no problem, but we need to hide the config button from the keyboard options, the user cannot access the desktop, so the only way any user can acces the configuration of onboard keyboard is by that simple config button.

Is there a way to start the virtual keyboard from command line without that button, or maybe a configuration file to modify?

Hope U can help me to solve this little issue!

thank you and Happy new year 2012 to all of you!

Question information

Language:
Spanish Edit question
Status:
Answered
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-17
Last reply:
2013-01-19

This question was reopened

marmuta (marmuta) said : #1

Happy new year. Yes, there is a configuration key to hide the preferences button and menu item:
$ gsettings set org.onboard.lockdown disable-preferences true
The button should be gone right away, the indicator menu item after restarting Onboard.

Aldo Ortega (afo-sys) said : #2

Thanks marmuta, that solved my question.

Aldo Ortega (afo-sys) said : #3

Got another inquiry... Do you have any list of options to disbale/enable? I found the quit and disable it, but I cannot find how to disable the F1..F12 buttons, or the acces to other no desired for kiosk keys? We want just to use the main keyboard only, and disable all special actions from the right of the keyboard (numeric keypad and Macros); just leave the "X" close to minimize!

Thank you for your help in advance!

marmuta (marmuta) said : #4

There are a couple of other lock-down settings. You can list them with
$ gsettings list-recursively org.onboard.lockdown

Disabling keys is possible since version 0.99 alpha with the gsettings key "disable-keys". However, this only deactivates the key's action, they will still be visible.

Try this to disable layer buttons, move and click buttons:
$ gsettings set org.onboard.lockdown disable-keys "[['LALT', 'TAB'], ['CTRL', 'LALT', 'F[0-9]+'], ['layer[0-9]+'], ['move'], ['showclick']]"
$ gsettings set org.onboard.lockdown disable-dwell-activation true

You can always modify the layouts yourself too and remove anything you don't need. If you share the result with us, we can perhaps include it with Onboard.

Can you help with this problem?

Provide an answer of your own, or ask Aldo Ortega for more information if necessary.

To post a message you must log in.