Show onboard in current desktop

Asked by David López on 2012-12-17

Hi. I made the following script (assigned to an easystroke movement) to show onboard 0.98 in my current desktop:

dbus-send --type=method_call --dest=org.onboard.Onboard /org/onboard/Onboard/Keyboard org.onboard.Onboard.Keyboard.Hide
dbus-send --type=method_call --dest=org.onboard.Onboard /org/onboard/Onboard/Keyboard org.onboard.Onboard.Keyboard.Show

That script showed onboard 0.98 in my current desktop in both situations:

- Onboard was hidden (first part of the script doesn't do anything, second part unhides in current desktop)
- Onboard was unhidden different desktop (first part hides in different desktop, second part unhides in current desktop)

I've updated to onboard 0.99 (trunk 1190) but the script only works when onboard is hidden; if onboard is unhidden in a different desktop, it remains unhidden in that different desktop, not in the current desktop.

For example, if onboard is unhidden in Desktop 1 and I call my script in Desktop 2, I expect that onboard hides in Desktop 1 and unhides in Desktop 2. That worked fine in onboard 0.98, but it doesn't work in 0.99 (onboard 0.99 remains unhidden in Desktop 1 and hidden in Desktop 2).

Any idea how to do this in onboard 0.99? Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2012-12-20
Last reply:
2013-02-22
marmuta (marmuta) said : #1

This looks like a bug. I haven't tried in OpenBox yet, but in Unity it somehow thinks it hides at an invalid position, unnecessarily tries to correct this and ends up at some bad position.
I'll open a bug report.

marmuta (marmuta) said : #2

David, could you please post the results of
$ gsettings list-recursively org.onboard.window

My desktop is 1366x768, and I have a 50px bar at the top of the screen, and 20px margins at left and right sides.

# gsettings list-recursively org.onboard.window

org.onboard.window background-transparency 92.0
org.onboard.window docking-edge 'bottom'
org.onboard.window docking-enabled true
org.onboard.window docking-shrink-workarea true
org.onboard.window enable-inactive-transparency true
org.onboard.window force-to-top false
org.onboard.window inactive-transparency 87.0
org.onboard.window inactive-transparency-delay 1.0
org.onboard.window keep-aspect-ratio false
org.onboard.window resize-handles ''
org.onboard.window transparency 64.0
org.onboard.window transparent-background false
org.onboard.window window-decoration false
org.onboard.window window-state-sticky false
org.onboard.window.landscape dock-expand true
org.onboard.window.landscape dock-height 295
org.onboard.window.landscape dock-width 700
org.onboard.window.landscape height 292
org.onboard.window.landscape width 1325
org.onboard.window.landscape x 19
org.onboard.window.landscape y 474
org.onboard.window.portrait dock-expand true
org.onboard.window.portrait dock-height 200
org.onboard.window.portrait dock-width 600
org.onboard.window.portrait height 200
org.onboard.window.portrait width 600
org.onboard.window.portrait x 100
org.onboard.window.portrait y 50

marmuta (marmuta) said : #4

David, I'll mark this question solved, since you confirmed the fix in Bug #1092166.