Resizing, moving OnBoard after screen rotate

Asked by Marnix Pikkemaat on 2012-01-04

On my tablet, after rotating the screen, a piece of the keyboard falls outside the display area. I'm able to reposition and rescale onboard using "onboard-settings -x XX -y YY ...". However, the settings dialog will always show after this command. Is there a way to prevent the dialog from showing?

Best Regards,
Marnix

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
marmuta
Solved:
2012-01-05
Last query:
2012-01-05
Last reply:
2012-01-05
Francesco Fumanti (frafu) said : #1

You do not have to call onboard-settings to pass it parameters of position and size; you can pass them directly to Onboard: "onboard -x XX -y YY ...".

By the way, if Onboard appears on the screen and is not fully visible, hiding and showing it should move it, so it is fully visible on the screen.

Marnix Pikkemaat (marnix-3) said : #2

Hi Frafu, thanks for your answer. I've tried "onboard -x XX...", but that starts a second instance of the keyboard. I could of course let the rotate script kill the current onboard, and start a new one with other settings, but I was wondering if there might be a cleaner way.

Francesco Fumanti (frafu) said : #3

I don't have a better idea at the moment; maybe that marmuta, the Onboard coder, has a better solution.

In any case, I filed a bug against Onboard about making it aware about rotating screens.

Best marmuta (marmuta) said : #4

Writing the position directly to gsettings should work. Try putting this in your script (for example):
gsettings set apps.onboard x 100
gsettings set apps.onboard y 50

Size can be changed too:
gsettings set apps.onboard width 300
gsettings set apps.onboard height 100

Marnix Pikkemaat (marnix-3) said : #5

Thanks marmuta, that solved my question.

Marnix Pikkemaat (marnix-3) said : #6

That worked like a charm, thanks! Is there also a gsetting for the icon's position when the keyboard is closed?

Marnix Pikkemaat (marnix-3) said : #7

Never mind, that was a lazy question. After browsing the code a bit, I found that

gsettings set apps.onboard.icon-palette x 200
gsettings set apps.onboard.icon-palette y 300

did the trick. Great stuff!