Sticky keys, changing layout, why red?

Asked by Steve Parker on 2011-11-25

First, thanks for this program, really useful.

Second, I'm creating my own layout, and I've been looking at the layouts that have been shipped with Onboard, and managed to almost get what I need. The only thing that is causing me issue, is changing layers.

Is there a way to press a button and a layer appears until the button is pressed again? At the moment you have to double-tap (the button turns red). I don't want the button to turn red.

Hope this makes sense and thank you for your time.

Question information

Language:
English Edit question
Status:
Answered
For:
Onboard Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-25
Last reply:
2011-11-26
marmuta (marmuta) said : #1

Hi, is this about the red color or don't you want to let the buttons enter the locked state?
In case you mean the button state, there is no way to influence this up to release 0.96.1, unfortunately. However, the current development version has an option to stop all keys from entering the (red) locked state. Check out bug lp #879944 for reference.

When the current states are
[off][latched][locked]

with the lockdown option apps.onboard.lockdown disable-locked-state they become
[off][latched]

where latched state switches back to layer 0 on each key press.

Is this what you need? Tweaking those lockdown options is still possible, they haven't been released yet. Also, could you explain why you need this?

Steve Parker (steve-parker43) said : #2

Thanks for the reply, I added the key with gconf-editor as seen in the screenshot (http://imgur.com/6Fm4s). However, this has made no change to the keyboard whatsoever. I'm using IceWM at the moment if that makes a different, on Ubuntu 11.10. The end goal is to make a kiosk unit, with Firefox as the browser, and Onboard as the interface.

The reason for no locked state keys is to emulate the iPhone/iPad keyboard, where you tap a key to switch to symbols, type all the symbols you desire and tap the symbol switch button again. The way I was attempting to do this is almost perfect but the locking keys adds an additional key press that is jarring if you don't know about the locking system.

I might be going about this the wrong way, but its so close to working, and your 'fix' above would have done the trick but its not working for me.

marmuta (marmuta) said : #3

I see, thanks for the explanation, good to know.
So, what you need would be to lock the layer buttons on first press. This isn't how the lock-down option I mentioned works unfortunately. It probably wouldn't be too hard to add one that does what you need though. I'll see if I can do that.

The other difficulty is that this is all brand new stuff, no lock-down option has been released yet. Ubuntu 11.10 now has a rather fresh version 0.96.1, but the lock-down keys aren't in there yet. The next release will probably have them, though Francesco may make it available in a PPA first.

One more thing, since your image shows gconf-editer. Onboard >0.96 has switched to gsettings and you would need to run dconf-editor (look in apps.onboard) instead. There are still no lock-down keys available until you have a version >0.96.1 installed, though (built from source).

The window manager shouldn't matter, though we don't explicitly test on IceWM atm.

marmuta (marmuta) said : #4

The current development version of onboard may have what you need now. Please check out the version in the Onboard Snapshots PPA at

https://launchpad.net/~onboard/+archive/snapshots

and let me know if it is sufficient.

Once installed you can change the modifier behavior with dconf-editor, (apps.onboard.keyboard.sticky-key-behavior) or from the command line with, for example:

gsettings set apps.onboard.keyboard sticky-key-behavior "['lock']"

This would lock all modifier and layer keys on first press and release them on second press. Other alternative behaviors are "cycle" (default), "dblclick" and "latch". There is a little more description to be found in dconf-editor.

Can you help with this problem?

Provide an answer of your own, or ask Steve Parker for more information if necessary.

To post a message you must log in.