Unable to resize or "unmaximize" after maximize

Asked by Lonnie Wall on 2010-10-03

I Enabled the onBoard virtual keyboard with a Netbook remix of Ubuntu 10.10 release candidate. I have a netbook tablet and use the virtual keyboard in tablet mode.

I wanted to see what the keyboard would look like maximized (was wondering if it just filled across the width), saw that it filled the whole screen, and am now stuck with the keyboard in a maximized state. The title bar is not available when the keyboard is maximized, hot keys don't work, and I searched your bug list and answers but couldn't find any similar issue.

There was one posting in a forum, but the guy answered himself by saying he modified the config. Unfortunatly I cannot find any file that holds dynamic configuration information or user settings for onBoard.

Please help! When displayed in maximized view it is completely unusable and I've tried for over two hours trying to figure out how to "unmaximize" the keyboard. It would also be nice if that button could be removed all together. Definitely sorry I clicked on it <g>

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Onboard Edit question
Assignee:
No assignee Edit question
Solved by:
Francesco Fumanti
Solved:
2010-10-03
Last query:
2010-10-03
Last reply:
2010-10-03
Best Francesco Fumanti (frafu) said : #1

If the title bar of onboard is present, but hidden under the upper GNOME panel, you can work around the problem by moving it away for a moment. (You can perform a right click on the GNOME panel to get to its properties.)

Or do you mean that onboard has no decoration after you have maximized it?

The user settings of onboard are stored in gconf keys, not in files; you can access them by using the gconf-editor. (You can install it by using the Synaptic Package Manager.)

Concerning the removal of the maximize button: we might do it perhaps if we solve the following bug:
https://bugs.edge.launchpad.net/onboard/+bug/564040

Lonnie Wall (wall) said : #2

When maximized there is no decoration.

With the Unity interface used in the Netbook remix the active application's menu is displayed in the upper GNOME panel and when maximized the buttons are also displayed in the upper panel. The panel also doesn't act like a title bar .. you can't double click on it to "unmaximize" the window where double-clickng the title bar of an app window will maximize it.

My understanding is that since the keyboard window sits on top of other active windows it's menu is not put into the upper GNOME panel and when maximized the buttons aren't placed there either.

using the gconf-editor resolved the issue. I was able to change the height, width, and placement values. When starting onBoard after making that change it was no longer maximized and I was able to resize it as needed.

Thanks!