Atmel maXTouch not working as claimed in 12.04

Asked by Lachlan

I have a Samsung Slate Series 7 PC, which has an Atmel maXTouch multitouch display. Here it says that this is supported by 12.04 :

I have installed a daily build of Ubuntu 12.04, and the touchscreen does not work. I do have the device showing up in lsusb as

03eb:211c Atmel Corp.

However, it does not show up in xinput -list.

When I tried Ubuntu 11.10, the touchscreen did work but it was handled as a Synaptics trackpad. It had some strange behaviour, and under 11.10 the Wacom pen did not work at all. The Wacom pen (separate from the Atmel touchscreen) DOES work in 12.04, and so I am continuing to use 12.04.

I am wanting to get this touchscreen working. Where can I find out more information about the testing that was done to claim that this device works under 12.04?

Question information

English Edit question
Open Input Framework Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was reopened

Revision history for this message
Chase Douglas (chasedouglas) said :

There is support for the touchscreen chip in a form that is typically used in embedded devices like tablets. There is a new form where the touchscreen is wrapped in a HID layer over USB. Patches for it were just accepted upstream, but likely won't be included in Ubuntu 12.04 LTS due to time constraints. Linux 3.3 and on should support your device though.

Revision history for this message
Lachlan (lachlan-rogers) said :

Thanks Chase Douglas, that solved my question.

Revision history for this message
Lachlan (lachlan-rogers) said :

Is it possible for me to find those patches and have a go at building my own kernel to get touch working in the meantime?

Revision history for this message
Lachlan (lachlan-rogers) said :

I found the relevant information at . I downloaded the vanilla 3.2.0 kernel and manually edited the three files in drivers/hid/ as outlined.

My touchscreen now works, except for two-finger touch. 3-finger and 4-finger gestures work fine. I'll ask about the 2-finger problem elsewhere, as this has now been solved.

Revision history for this message
Bernard Victor Delvaux (nadaeck) said :


I have this tablet also and indeed the 3.3 version of the kernel seem to work perfectly natively regarding multitouch, including 2 fingers.

Just one thing: before compiling, I did a 'make oldconfig' on my Ubuntu 11.10 and I had to enable (as a module) the 'Intel Wireless WiFi Next Gen AGN - Wireless-N/Advanced-N/Ultimate-N (iwlwifi)' driver to have wifi working properly.


Revision history for this message
Lachlan (lachlan-rogers) said :


Did you just compile a 3.3 kernel in Ubuntu 11.10? Do you have the settings panel in "mouse and touchpad" to enable 2-finger scrolling, or did it just work?

I'm also interested to know if you have screen rotation working for the touch input. I could rotate the display and the wacom pen input, but not the touch input.

- Lachlan

Revision history for this message
Bernard Victor Delvaux (nadaeck) said :


I apologize for the late answer; I had forgotten to activate the email notification if I get an answer.
Yes I just compiled a 3.3 kernel in Ubuntu 11.10 and it worked out of the box but I didn't try the 2 fingers scrolling. I can just say that 2 to 5 fingers input is detected natively as confirmed by using Ginn; also in my app, that uses libutouch-geis, 2 fingers pinch/spread works natively also...

I am not a big fan of Unity until now. However, I will try to see how other things you have mentioned work.


Revision history for this message
z (steveriley-deactivatedaccount-deactivatedaccount) said :

More data points... I have one of these Samsung 700t tablets, too. I've been struggling for some time trying to get any form of *buntu to run and be useful. I can finally report some success: I downloaded and installed the Kubuntu Active build of 12.04 ( and it's functional enough to be a near-daily driver. Scrolling with the finger works and the on-screen keyboard works. I had to bump up X from 1.11 to 1.12 using Xorg-Edgers, though. Multitouch isn't working, and neither is the digitizer pen.

I've been working on this little side project for some time. If you're curious, I've documented my progress in various places.

First attempt, described at Ubuntu Forums

A post chronicling some experimentation with UEFI (on ThinkPads, but relevant as the Samsung is UEFI)

Initial, if incomplete, success at getting Ubuntu to boot

My rant about Microsoft "accidentally" sending me a 1099, claiming I owed taxes on the tablet

Balsam's build of Plasma Active Two, running but mostly non-functional

First actual useful install, KFN post created with Kubuntu Active

15-minute video tour of my initial experimentation with Plasma Active

Revision history for this message
Cédric Dufour (cdufour-keyword-ubuntu-086000) said :


I also have a Samsung XE700 with the Atmel maXTouch touchscreen and getting very frustrated!

Be it with (X)Ubuntu 12.04 stock kernel (3.2.0-24) and stock 'hid-multitouch' driver, stock kernel and latest GIT driver (2012.03.13 for Ubuntu 12.04) or Quantal's 3.4.0-1 kernel and driver (the latter being identical to the GIT driver), I have no success at all.

touchscreen is reported by xinput (but no mention of any "multitouch" feature; don't know if there should be any).
mtview shows multitouch works (2-, 3- or 4-fingers).
ginn recognizes multitouch gestures (2-, 3- or 4-fingers).
BUT neither Unity nor XFCE seem to recognize it.
(not mentioning that XFWM, XFCE's windows manager, is buggy with the multitouch device: windows bar buttons are totally unresponsive; openbox "hack" works)

My main concern is having a working right-click (no such big deal, one would think; but...).
2-fingers tap does not work.
Third Mouse Button Emulation does not work (though it works flawlessly on an Asus T91 and Xubuntu 12.04)

There is something else than the kernel/driver preventing this device to work as expected, either as a genuine multitouch device or at least as a simple single-finger touchscreen.
Faulty Xorg' EVDEV driver?
Some hidden configuration trick?

Revision history for this message
Cédric Dufour (cdufour-keyword-ubuntu-086000) said :

Correction: using both stock kernel/driver from Precise and Quantual, 3- and 4-fingers gestures work (under Unity). 2-fingers don't.

Revision history for this message
Stephen M. Webb (bregma) said :

Support for various one- and two-finger gestures in applications is still in its early days and by and large missing. There is some legacy support for touchpad gestures in the Synaptics driver, but this is not used for (most) touchscreens. Application support for touchscreen gestures is still a work in progress.

Revision history for this message
Cédric Dufour (cdufour-keyword-ubuntu-086000) said :

Is there any way to force a touchscreen (e.g. Atmel maxTouch) to be recognized and behave like a simple touchpad (with working right-click emulation and optionally two-fingers scrolling)?
At which level could this be done?
Configuration (modprobe.d, xorg.conf, etc.)?
Hacking's evdev code?
Hacking's synaptics code?
Hacking hid-multitouch code?

Revision history for this message
Cédric Dufour (cdufour-keyword-ubuntu-086000) said :

Independently from applications natively supporting touchscreen, something is still wrong with the hid-multitouch+evdev stack (at least when it comes to the Atmel maXtouch):

After starting (or restarting) X, everything runs fine (1-finger click as well as 2- to 5-fingers gestures) until at some point, 1-finger click is lost (though pointer still follows the finger on the touchscreen) and multitouch becomes whimsical (at this point, restarting X solves the problem). That issue shows up both on Xubuntu (XFCE) and Ubuntu (Unity).

I have:
 - the almost-latest hid-multitouch driver, (commit 3ac36d15557d1bedfb1151d9911b9587b2d40759) taken from the GIT repository (and stripped from Jiri Kosina's change that make it incompatible with the 3.2 HID USB stack)
 - tried Xubuntu's stock xserver-xorg-input-evdev or the latest version (commit 9624f4e2ba7d1973813de066806eed108748a53a) taken from' GIT repository)

Using the almost-latest hid-multitouch driver (or maybe some Ubuntu update meanwhile) allowed to solve the touchscreen becoming even more whimsical and behaving even more erratically as it does now. Ginn is thus now fully usable and behaves as expected... until that "1-finger click is lost and multitouch becomes whimsical" issue.

I'm available for testing patches of stuff if it can help solve the issue.


Revision history for this message
Cédric Dufour (cdufour-keyword-ubuntu-086000) said :

Eventually, it seems (to me) this issue is now identified as bug (and actually a X Server core's bug)

Revision history for this message
Martin von Gagern (gagern) said :

> I'm available for testing patches of stuff if it can help solve the issue.
> Eventually, it seems (to me) this issue is now identified as bug #1015183

In that case, please give the package from a try. In case you're worries about security, you can of course apply the patches from the bug #1015183 report manually. If that solves your problem, you might want to link this question to that bug report.

Revision history for this message
Lachlan (lachlan-rogers) said :

I also experience the loss of touch click. Recently I have had to use Libreoffice a bit, and when I lose the left click in Libreoffice it comes back once I close Libreoffice. Could this be a separate Libreoffice bug?