How do I enable touch on the classic desktop?

Asked by Duncan McGreggor on 2011-03-18

After this question was answered:
  https://answers.launchpad.net/utouch/+question/149377

victor (https://launchpad.net/~nadaeck) had a follow-up question, which deserved an entry of its own (and inspired several wiki page updates):

  "However since I'm not familiar enough with Unity, i'd like to stick for now with the classic desktop. Could you tell me how to activate [touch] without Unity?"

Question information

Language:
English Edit question
Status:
Solved
For:
Open Input Framework Edit question
Assignee:
No assignee Edit question
Last query:
2011-03-18
Last reply:
2011-03-18
Duncan McGreggor (oubiwann) said : #1

Thanks for the question, victor! You inspired me to do the following:
 * Update the main wiki page with a "Quick Start" section at the top (https://wiki.ubuntu.com/Multitouch#Quick Start)

 * Add a wiki page for getting started with Natty (https://wiki.ubuntu.com/Multitouch/GettingStarted/Natty)

 * Add a wiki page for getting started with Maverick (https://wiki.ubuntu.com/Multitouch/GettingStarted/Maverick)

If there are any missing details there, feel free to leave a comment here, and we'll address them for you.

Thanks again!

Duncan McGreggor (oubiwann) said : #2

Updated status to "Answered" (instead of "Solved") just in case victor has more questions...

Let's break it into categories:

* Single Touch:
works out-of-the-box

* Mutli-touch:
works from Natty with the xi2 extension to X.
There is some support in libraries and you can create simple application using it.

* Gestures:
1. They work since Maverick using Ginn, you can define rules for gestures and get control of any app (key/btns injection)
2. Support of gestures in some modified applications : eog, evince,
3. Support in Unity with the dash gestures etc.

So, if we remove the last option, you still have all others even in the classical gnome desktop.

Duncan McGreggor (oubiwann) said : #4

Yup, this information is covered in the wiki pages I created (the definitive resource, since we can update it with future changes, backports, etc.)

Thank you very much all for your help.

However in my case, it still doesn't work after the installation of the uTouch package. I'm talking only about the 3- or 4-fingers gestures (the point 3 of the 'Gestures' paragraph of Mohamed's post). So now it works perfectly in Unity but it doesn't without Unity, in the Maverick's classic desktop....

On the other hand Ginn still works perfectly

Is it normal?

Thank you again for your kind help; this project is really great!

Duncan McGreggor (oubiwann) said : #6

Yes,

This is normal -- the 3- and 4-finger gestures are system gestures as defined by Unity. If you're not using unity, you don't have the system gestures.

I mentioned this on the "Natty" getting-started page, but not the Maverick one -- however, I just updated the Maverick page so that it states this clearly as well.

Both pages mention that you can use Ginn with your preferred window manager to configure 3- and 4-finger gestures.

Hope that helps!

Thanks for your interest in it !

You can have similar effects by matching those gestures in ginn to Compiz
shortcuts
I have recorded some videos showing that:
https://wiki.ubuntu.com/Multitouch/Ginn

Yes this helped me

For me the question is definitely solved; thank you so much!

Victor

Duncan McGreggor (oubiwann) said : #9

Glad we could help, victor!

Duncan McGreggor (oubiwann) said : #10

Marking as solved; victor has everything he needs now :-)

Duncan McGreggor (oubiwann) said : #11

Also, victor: I've posed this question to Ikbel "How does a user configure ginn for unity-like gestures?":
  https://answers.launchpad.net/ginn/+question/149605

He'll be putting that in the wiki when he's done, so that should be helpful for you as well :-)