ubuntu 10.10 on HP tx1000

Asked by Johannes Rustan on 2010-10-15

how can i set my hp tx1000 for multitouch?

Question information

Language:
English Edit question
Status:
Answered
For:
Open Input Framework Edit question
Assignee:
Chase Douglas Edit question
Last query:
2010-11-08
Last reply:
2011-02-24

The latest Ubuntu release already comes with multitouch support.

Fabián Rodríguez (magicfab) said : #2

@Johannes I am looking into this, I'll get an answer for you shortly.

Fabián Rodríguez (magicfab) said : #3

Hi Johannes, it took me sometime to enable the touchscreen for regular use on my tx1220 laptop. I assume you have the same touchscreen as mine, identified by lsusb:
0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen

Right now multitouch support is really driven by the community so the end result will depend on who provides input / testing on this particular device. I will be at UDS next week with mine so I should be able to get some progress on it. Meanwhile if you have new information please submit it here.

The first two tests I did with this device failed, namely:
https://wiki.ubuntu.com/Multitouch/Testing/CheckingMTDevice ("error: could not grab the device", as sudo)
https://wiki.ubuntu.com/Multitouch/Testing/UsingGesturetest (no output)

Let me know if you have the same results

Johannes Rustan (jhn-rustan) said : #4

lsusb :
Bus 002 Device 004: ID 1199:6856 Sierra Wireless, Inc. ATT "USB Connect 881"
Bus 002 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 007: ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen
Bus 001 Device 006: ID 08ff:1600 AuthenTec, Inc. AES1600
Bus 001 Device 005: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 002: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

https://wiki.ubuntu.com/Multitouch/Testing/CheckingMTDevice
sudo lsinput
/dev/input/event6
   bustype : BUS_USB
   vendor : 0xeef
   product : 0x1
   version : 528
   name : "eGalax INC. USB TouchController"
   phys : "usb-0000:00:0b.1-2.3/input0"
   uniq : ""
   bits ev : EV_SYN EV_KEY EV_ABS EV_MSC

/dev/input/event7
   bustype : BUS_USB
   vendor : 0xeef
   product : 0x1
   version : 528
   name : "eGalax INC. USB TouchController"
   phys : "usb-0000:00:0b.1-2.3/input0"
   uniq : ""
   bits ev : EV_SYN EV_KEY EV_ABS EV_MSC

joe@johannes:~$ sudo mtdev-test /dev/input/event7

012bdd91b8e7 00 4 0004 852034
012bdd91b8e7 00 1 014a 1
012bdd91b8e7 00 3 0000 706
012bdd91b8e7 00 3 0001 2120
012bdd91b8e7 00 0 0000 0
012bdd91b8f7 00 3 0000 707
012bdd91b8f7 00 3 0001 2119
012bdd91b8f7 00 0 0000 0
012bdd91b907 00 3 0000 708
012bdd91b907 00 3 0001 2118
012bdd91b907 00 0 0000 0
012bdd91b923 00 3 0000 707
012bdd91b923 00 3 0001 2117
012bdd91b923 00 0 0000 0
012bdd91b943 00 3 0001 2116
012bdd91b943 00 0 0000 0
012bdd91b983 00 3 0001 2117
012bdd91b983 00 0 0000 0
012bdd91b9a3 00 3 0000 708
012bdd91b9a3 00 3 0001 2125
012bdd91b9a3 00 0 0000 0
012bdd91b9b9 00 3 0000 710
012bdd91b9b9 00 3 0001 2144
012bdd91b9b9 00 0 0000 0
012bdd91b9c9 00 3 0000 711
012bdd91b9c9 00 3 0001 2170
012bdd91b9c9 00 0 0000 0
012bdd91b9d9 00 3 0000 712
012bdd91b9d9 00 3 0001 2198
012bdd91b9d9 00 0 0000 0
012bdd91b9e3 00 3 0000 711
012bdd91b9e3 00 3 0001 2226
012bdd91b9e3 00 0 0000 0
012bdd91b9eb 00 3 0000 710
012bdd91b9eb 00 3 0001 2252
012bdd91b9eb 00 0 0000 0
012bdd91b9f3 00 3 0000 708
012bdd91b9f3 00 3 0001 2274
012bdd91b9f3 00 0 0000 0
012bdd91b9fb 00 3 0000 706
012bdd91b9fb 00 3 0001 2292
012bdd91b9fb 00 0 0000 0
012bdd91ba03 00 3 0000 704
012bdd91ba03 00 3 0001 2306

gesturetest 0 0 0xffffffff
did not any output

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Johannes Rustan (jhn-rustan) said : #6

anybody know how to solvede it?

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Duncan McGreggor (oubiwann) said : #8

Hey Chase, here's another hardware one. Can you follow up where Fabian left off?

I'm pretty sure the tx1000 is a 2-touch wacom device...

Chase Douglas (chasedouglas) said : #9

I think there was a bug in the eGalax driver that prevented it from working properly. I would try it again with an up to date 10.10 kernel, or natty if the reporter is feeling up to it.

Can you help with this problem?

Provide an answer of your own, or ask Johannes Rustan for more information if necessary.

To post a message you must log in.