HP tx1000 won't work

Asked by Johannes Rustan on 2010-10-13

after i upgrade from ubuntu 10.04 to ubuntu 10.10, i cannot use my touch screen

anyone can help me?

thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Open Input Framework Edit question
Assignee:
No assignee Edit question
Solved by:
Johannes Rustan
Solved:
2010-10-14
Last query:
2010-10-14
Last reply:
2010-10-13
Stephen M. Webb (bregma) said : #1

This device uses the N-Trig touchscreen. You likely need a firmware upgrade to your hardware. There are some notes on this at <https://wiki.ubuntu.com/Multitouch/#N-trig>.

Fabián Rodríguez (magicfab) said : #2

@Johannes, I have a tx1220ca, very similar. Can you share the result of lsusb ?
My touchscreen works but the cursor stays in the top corner in 10.04. Can you share how your system worked in 10.04 ?

Johannes Rustan (jhn-rustan) said : #3

@stephen:
with ubuntu 10.10, how can i check my firmware?

@Fabian :

in ubuntu 10.04 work, i just add
xinput --set-int-prop "eGalax INC. USB TouchController" "Device Enabled" 8 0

at startup application, and i can calibrate it and work
and edit fdi file for touchscreen, i forget what file it's but it content
option Minx, MinY, untouch status, touch status
i cannot tell you the file, because i have already upgrade it, and now it's gone

but in 10.04, it cannot detect my touchscreen and work well

this is my lsusb (ubuntu 10.10)

Bus 002 Device 003: ID 04b8:0005 Seiko Epson Corp. Stylus D88+ / C43UX
Bus 002 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen
Bus 001 Device 004: ID 08ff:1600 AuthenTec, Inc. AES1600
Bus 001 Device 003: ID 0c45:62c0 Microdia Sonix USB 2.0 Camera
Bus 001 Device 002: ID 04b4:6560 Cypress Semiconductor Corp. CY7C65640 USB-2.0 "TetraHub"
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

should i turn back to ubuntu 10.04? but i think ubuntu 10.10 is better for connect my GSM modem, it had a choice for 3G prefered and work more better than 10.04

Johannes Rustan (jhn-rustan) said : #4

*) but in 10.04, it cannot detect my touchscreen and work well <---sorry , miss type

but in 10.04, it can detect my touchscreen and work well <---

Johannes Rustan (jhn-rustan) said : #5

work now on ubuntu 10.10

my xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 260.19.06 (buildd@palmer) Mon Oct 4 16:01:38 UTC 2010

Section "ServerLayout"
        InputDevice "EETI" "SendCoreEvents"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Nvidia Default Flat Panel"
    HorizSync 29.0 - 49.0
    VertRefresh 0.0 - 61.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce Go 6150"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "1280x800 +0+0; 1024x768 +0+0"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

### Touch Configuration Beginning ###
Section "InputDevice"
        Identifier "EETI"
        Driver "egalax"
        Option "Device" "/dev/input/event6"
# Option "Parameters" "/var/lib/eeti.param"
# Option "ScreenNo" "0"
# Option "SkipClick" "0"
 Option "MinX" "53"
 Option "MaxX" "3800"
 Option "MinY" "53"
 Option "MaxY" "3800"
        Option "SendCoreEvents"
        Option "SwapY" "1"
        Option "Emulate3Buttons"
        Option "Emulate3Timeout" "50"

EndSection
### Touch Configuration End ###

and add "usbhid.quirks=0xeef:0x1:0x40" to /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap usbhid.quirks=0xeef:0x1:0x40"

sudo update-grub

now my touch screen normal again.......

Fabián Rodríguez (magicfab) said : #6

@Johannes, many thanks, that's very useful. If the only reason you upgraded to 10.10 is the modem, you can try this in 10.04LTS:
- Boot from a live CD
- install the usb-modeswitch package
- Remove-reinsert the stick
- Network manager should now see the stick and let you use/configure it

usb-modeswitch is now included in 10.10 but as you see it's trivial to add in 10.04 LTS. If you want more information about this please open a separate question.